Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите, пожалуйста, составить программу(Паскаль): Даны действительные числа x, y, z.

10-11 класс

Вычислить min

лелик13579 21 февр. 2017 г., 19:50:54 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Daryamiass
21 февр. 2017 г., 22:47:42 (7 лет назад)

var

  x, y, z, res : real;

 

function min2 (a, b : real) : real;

begin

  if a < b then min2 := a else min2 := b;

end;

 

begin

  read (x, y, z);

  res := min2 (x + y + z / 2, x* y * z)+1;

  writeln (res);

end.

Ответить

Другие вопросы из категории

С помощью азбуки Морзе можно кодировать символ для сообщений по радиосвязи, используя комбинацию точек и тире. Определите количество различных

символов, которых можно закодировать, используя код азбуки Морзе длиной не менее трёх и не более пяти сигналов (точек и тире)? В ответе укажите только число.

Помогите пожалуйста решить)
В каком порядке будут расположены слова, если

упорядочить их по УБЫВАНИЮ суммы кодов символов в таблице кодировки ASCII?
1) окно 2) кино 3) ника 4) конь 5) ночь

Паскаль

Дано число n, вектор а=(а1,а2,...аn) и числа AиВ (А<B) Найти сумму тех координат ak, для которых выполняется условие: А≤аk≤В.

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Помогите пожалуйста написать программу в паскале.

Составить программу перевода натурального числа из десятичной системы счисления в двоичную

10-11 класс информатика ответов нет
Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".



Вы находитесь на странице вопроса "Помогите, пожалуйста, составить программу(Паскаль): Даны действительные числа x, y, z.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.