Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помоги пожалуйста составить в Паскале. У меня никак не получается

10-11 класс

SkanDal1999 16 марта 2017 г., 21:00:32 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Holinam
16 марта 2017 г., 23:04:26 (7 лет назад)

задание 1.2
uses crt;
var r,c,b,a:real;
begin
a:=1;
b:=1;
c:=3.14;
r:=((abs(a)+abs(b)/2+sin(c))+(a+b/abs(a+b)))/(1+ln(2+cos(c)));
writeln('r=',r);
end.

Ответить

Другие вопросы из категории

Помогите,пожалуйста

2.написать примеры оператора вывода данных и работу ЭВМ с этим оператором

Для кодирования цвета фона интернет-страницы используется атрибут bgcolor="#ХХХХХХ", где в кавычках задаются шестнадцатеричные значения

интенсивности цветовых компонент в 24-битной RGB-модели следующим образом:

С помощью азбуки Морзе можно кодировать символ для сообщений по радиосвязи, используя комбинацию точек и тире. Определите количество различных

символов, которых можно закодировать, используя код азбуки Морзе длиной не менее трёх и не более пяти сигналов (точек и тире)? В ответе укажите только число.

Читайте также

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите решить задачу на паскале, очень нужно:

Дана строка, удалить текст находящийся в скобках (вместе со скобками)

Я тут начал делать, вот только с удалением у меня ничего не получается, напишите как можно сделать

Вот как я делал:
program zd;
uses crt;
var s:string; i,l,n,t,y:integer;
begin
clrscr;
writeln('Введите строку');
readln(s);
l:=length(s);
for i:=1 to n do begin
if s[i]='(' then
t:=i; {здесь присваивал номер найденной скобки}
if s[i]=')' then
y:=i; {так же, как и выше}
delete (s,t,i); {у меня получается, что он удаляет с открывающей скобки и всё что находится вправо, а левая часть до скобки остается нетронутой}
end;
writeln('Данный результат =', s);
readln;
end.

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)



Вы находитесь на странице вопроса "Помоги пожалуйста составить в Паскале. У меня никак не получается", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.