Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Пожалуйста помогите, задачи в Паскале:

5-9 класс

1)Заполнить массив случайными числами от -100 до +100
и распечатать на экране только отрицательные числа
2)Дан массив из 20 элементов числа от -50 до +50
а)Каждый элемент больше 10 заменить на его квадратный корень
б)Все элементы с четными номерами заменить на их абсолютную величину(модуль)
в)Ко всем отрицательным элементам прибавить 5 , а к остальным первый элемент массива

Vasunina71 20 авг. 2013 г., 6:27:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
1221ff
20 авг. 2013 г., 8:06:07 (10 лет назад)

var
  i:integer;
  a:array[1..20]of integer;
begin
for i:=1 to 20 do
  begin
  a[i]:=random(-100,100);
  if a[i]<0 then write(a[i],' ');
  end;
end.

2)
а)

+ 0 -
182003
20 авг. 2013 г., 8:43:16 (10 лет назад)

Во втором все в одной программе делать или для каждой буквы отдельно?

+ 0 -
SOOS
20 авг. 2013 г., 10:54:07 (10 лет назад)

Желательно отдельно

Ответить

Другие вопросы из категории

флэш-карта имеет объём 512 мбайт рукопись содержит 2000 страниц. На каждой странице 80 строк в каждой строке 100 символов. Каждый символ кодируется 16-ю

битами. Кроме того, рукопись содержит 80 иллюстраций объёмом 5 Мбайт каждая. Поместится ли рукопись на флэш-карту и какой её объём в Мегабайтах?

Читайте также

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!

Пожалуйста, помогите!!!!!!!!!! Известно, что в 12-летнем цикле года носят вои названия: мышь, корова, тигр, заяц, улитка, змея, лошадь, овца,

обезьяна, курица, собака и свинья. Зная, что 1984 год был годом мыши, написать программу, выводящую номер года и его название.

Учитель сказал, что это решается через кейс..Только как.ПОЖАЛУЙСТА, ПОМОГИТЕ!!!!!!!!!!

Помогите пожалуйста с задачами на паскаль.

1)вычислите длину окружности и круга по данному радиусу входные-длина окружности, s,l-выходные
2)Найти площадь кольца с внутренним радиусом r1 и внешним r2
3)Даны 2 положительных действительных. Найти средние арифметическое и средние геометрическое a,b - входные данные, (a,b)*2 -ср. арифмет.



Вы находитесь на странице вопроса "Пожалуйста помогите, задачи в Паскале:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.