Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Пожалуйста ПОМОГИТЕ!

5-9 класс

Составьте программу для решения задач:
1.Найдите произведение квадратных корней N первых натуральных чисел
2.Определить делится ли сумма цифр заданного натурального числа на 7
3.Заменяет в записи натурального числа N цифру 8 на цифру 3

Lizabakina27 28 авг. 2013 г., 17:08:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angel1naGoldman3
28 авг. 2013 г., 19:41:07 (10 лет назад)

1.
var
n, i: integer;
rez: real;
begin
rez:=1;
readln(n);
for i:=1 to n do rez:=rez*sqrt(i);
write(rez);
end.

2.
var
n: string;
i, summa: integer;
begin
readln(n);
for i:=1 to length(n) do summa:=summa+strtoint(n[i]);
if (summa mod 7)=0 then write('Делится') else write('Не делится');
end.

3.
var
n: string;
i, summa: integer;
begin
readln(n);
for i:=1 to length(n) do if n[i]='8' then n[i]:='3';
write(n);
end.

Если возникли вопросы или ошибки в ходе работы программы, пиши в ЛС или комментарии.

Ответить

Другие вопросы из категории

Видеопамять делится на 4 странице .

Разрешающая способность дисплея - 640 x 200
Вычислить объем видеопамяти ,если битовая глубина равна 16 .

Пожалуйста помогите, задачи в Паскале:

1)Заполнить массив случайными числами от -100 до +100
и распечатать на экране только отрицательные числа
2)Дан массив из 20 элементов числа от -50 до +50
а)Каждый элемент больше 10 заменить на его квадратный корень
б)Все элементы с четными номерами заменить на их абсолютную величину(модуль)
в)Ко всем отрицательным элементам прибавить 5 , а к остальным первый элемент массива

флэш-карта имеет объём 512 мбайт рукопись содержит 2000 страниц. На каждой странице 80 строк в каждой строке 100 символов. Каждый символ кодируется 16-ю

битами. Кроме того, рукопись содержит 80 иллюстраций объёмом 5 Мбайт каждая. Поместится ли рукопись на флэш-карту и какой её объём в Мегабайтах?

Читайте также

Пожалуйста, помогите!!!!!!!!!! Известно, что в 12-летнем цикле года носят вои названия: мышь, корова, тигр, заяц, улитка, змея, лошадь, овца,

обезьяна, курица, собака и свинья. Зная, что 1984 год был годом мыши, написать программу, выводящую номер года и его название.

Учитель сказал, что это решается через кейс..Только как.ПОЖАЛУЙСТА, ПОМОГИТЕ!!!!!!!!!!

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!

Пожалуйста помогите по информатике

1) исключи лишнее:
а)микрофон, б)колонки, в) наушники , г) монитор
2)исключи лишнее:
а)процессор, б) монитор, в)клавиатура, мышь
3)установите соответствие. Устройство ПК:
1. клавиатура
2. модем
3.центральный процессор
назначение устройств:
а)передача цифровой информации через каналы связи
б)хранение информации
в)обеспечение общего управления ПК, осуществление вычислений по программе, хранящейся в оперативной памяти
г)визуальное отображение информации, находящейся в оперативной памяти
д)ввод алфавитно-цифровых символов
6.Раздели на группы и дай название каждой группе:
а)принтер,б)сканер,г)мышь,д)проектор,е)веб камера,ж)процессор,з)колонки,и)микрофон, к) монитор
Пожалуйста помогите очень срочно.

Это не по уроку. Если у кого случалась такая ситуация, помогите пожалуйста!

Раньше у меня был комп, он был ну оооочень старый где то 2002г. Так вот, я решила скрыть папку со своими фотографиями и после этого я не смогла ни где их найти.
Пожалуйста помогите! Что сделать чтобы вернуть папку.

Пожалуйста помогите!

переведите число 52810 в двоичный код!
помогите Пожалуйста



Вы находитесь на странице вопроса "Пожалуйста ПОМОГИТЕ!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.