Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Используя датчик случайных чисел, заполнить двумерный массив не повторяющимися числами.

10-11 класс

Нужно на языке Паскаль.

МилаяКошка 31 июля 2014 г., 15:27:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Demaynenkoxeni
31 июля 2014 г., 17:45:26 (9 лет назад)

ПаскальАВС.НЕТ

const
  n=5;
  m=10;
var
  a:array[,]of integer;
  i,j:integer;

function povtor(x,y:integer;var a:array[,] of integer):boolean;
var i,j,jm:integer;
begin
povtor:=false;
for i:=1 to x do
  begin
  if i=x then jm:=y-1 else jm:=m;
  for j:=1 to jm do
    if a[i,j]=a[x,y] then povtor:=true;
  end;
end;  

begin
setlength(a,n+1,m+1);
for i:=1 to n do
  begin
  for j:=1 to m do
    begin
    a[i,j]:=random(n*m*2);
    while povtor(i,j,a) do a[i,j]:=random(n*m*2);
    write(a[i,j]:4);
    end;
  writeln;
  end;
end.  

Ответить

Другие вопросы из категории

10. Составьте

программу, которая вводит
с клавиатуры три
целых числа: a, b, c (каждое
число с новой
строки) и выводит
на экран максимальное
из них. Ничего
кроме этого числа,
программа выводить не
должна.

посчитать сумму элементов от 1 до 5
нарисуйте блок схему по листингу задачи.Даша Пупырышкина изучает английский язык во втором классе. Ей задали домашнее задание: переписать

английские слова, записанные строчными буквами, в тетрадь. Выполняя задание, она комментирует его. Даша произносит слово "Опять" каждый раз, когда пишет букву, которая уже встречалась в слове раньше.
Составьте программу, которая по слову определяет: сколько раз Даша произнесёт "Опять".
Примеры:
Исходное слово apple Ответ 1 раз
Исходное слово potato Ответ 2 раза
Ваша программа должна
Запросить слово;
Подсчитать сколько раз, переписывая это слово, Даша произнесёт "Опять" и вывести это число на экран.



program dasha;
var s: string;
x, l, i, y, j: byte;
begin
writeln('введите слово');
readln(s);
l := length(s);
y := 0;
for i:=1 to 1-1 do
for j:=i+1 to l do
if (s[i] = s[j]) then y := y+1;
writeln('Даша скажет опять', y, ' раз');
end.

СРОЧНО ПЛИИИЗ Задача: Дано действительное число Х, вычислить

(x-1)(x-3)(x-7)...(x-63)/(x-2)(x-4)(x-8)...(x-64) (дробь)

Используя оператор: while
Не могу написать через данный оператор программу на паскаль, выходит всегда число 0. Прошу помочь мне :)

Читайте также

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

Определить для массива X(n) алгебраические суммы четных и нечетных элементов массива. Вывести исходный массив и полученные значения. Упорядочить массив X(n

) по возрастанию. Вывести полученный массив. Исходный массив элементов получить с помощью датчика случайных чисел. Значения буквенных переменных задавать с клавиатуры.
Помогите написать программу в QBasic и нарисовать блок-схему(необязательно)



Вы находитесь на странице вопроса "Используя датчик случайных чисел, заполнить двумерный массив не повторяющимися числами.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.