Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Построить формулу для определения зависимости y от x с использованием логичесикх функций и,или,если,не y=/45/

10-11 класс

0<x<20,30<x<70

/x/ -10<x<0

/x-4/ 80<x<100,110<x<140,180<x

/x4/ -20<x<0

/x+2/ все остальные

MadFury 13 марта 2016 г., 12:52:31 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zarinadlimbet
13 марта 2016 г., 15:18:33 (8 лет назад)

var
    y, x: real;

begin
    read(x);
    if (x > -20) and (x < -10) then
        y := x * x * x * x
    else if (x > -10) and (x < -20)  then
        y := abs(x)
    else if ((x > 0) and (x < 20)) or ((x > 30) and (x < 70))  then
        y := 45
    else if ((x > 80) and (x < 100)) or ((x > 110) and (x < 140)) or (x > 180)  then
        y := abs(x - 4)
    else
        y := abs(x + 2);
   
    writeln(x, ' ', y);
end.

Ответить

Другие вопросы из категории

Нужно написать программу в Паскале

Дан механизм,состоящий из двух шестеренок. У одной шестеренки N зубцов,у другой K. Требуется найти какое минимальное число поворотов на один зубчик требуется сделать,чтобы шестеренки вернулись в исходное состояние.

решите в паскале ABC: Вы стоите на краю дороги и от вас до ближайшего фонарного столба x метров. Расстояние между столбами y метров. На каком

расстоянии от вас находится n-й столб?

Та же ситуация, что и в предыдущей задаче. Длина вашего шага

В алфавите племени мамба есть всего 3 буквы: а, б, м, которые в текстах мамбийского языка встречаются с такой частотой: а - 60%, б - 10%, м - 30%.

Предложите самое экономное компьютерное кодирование мамбийського алфавита. Тоесть такое, что будет давать возможность хранить мамбийськи тексты с помощью наименьшего количества битов в среднем.

Читайте также

1. При совершении сделки купец получил 12 одинаковых по виду золотых монет. Ему стало известно, что одна из монет фальшивая и отличается от настоящей

монеты только весом. Для определения фальшивой монеты он пронумеровал монеты числами от 1 до 12 и провел три взвешивания на рычажных весах. Обозначив через Vi – вес монеты с номером i, он записал результаты взвешиваний следующим образом: V2 + V4 + V5 + V6< V3 + V7 + V8 + V9; V1 + V2 + V3 + V5> V4 + V6 + V10 + V11; V1 + V4 + V7 + V10>V5 + V6 + V9+ V12. Найдите фальшивую монету.

Ребят, помогите, пожалуйста! В excel нужно построить на промежутке [-2;2] с шагом 0,4 таблицу значений функции: y= x в квадрате+0,2х для х меньше равно 0,

sin(0,1x) для х больше равно 0. Построить график полученной функции. Спасибо заранее

Дан фрагмент программы. Нарисуйте блок-схему, восстановите вид формулы для расчета S

PASCAL:

VAR
A:ARRAY[1...100]OFF
INTEGER;
N,I,J: INTEGER;
S: REAL;
BTGIN
N:=8;
FOR I:=1 TO N DO
BEGIN
S:=0;
FOR J:=1 TO I DO
S:=S+(A[J]);
S:=ABS(S);
WRITELN(`S`=`,S:9:2);
END;
READLN;
END.

QBASIC
DEFINT N,I,J,S,
DIM A(100) AS INTEGER
N:=8
FOR I=1 TO N
S=0
FOR J=1 TO I
S=S+A[J]
NEXT J
S=ABS(S)
PRINT S
NEXT I

ШКОЛЬНЫЙ АЯ

алг слово(рез вещ s)
цел раб А[1:100]
n:=8
нц для I от 1 до n
s=0
нц для j от 1 до I
s=s+a[j]
кц
s=abs(s)
вывод s
кц
кон

Пожааалуйста нужны блок-схемы для трех вариантов получения s





«Технология обработки числовой информации» Excel Вопрос 1. ЭТ – это 1)Прикладная программа, предназначенная

для обработки структурированных в виде таблицы данных

2)Прикладная программа для обработки кодовых таблиц

3)Устройство ПК, управляющее его ресурсами в процессе обработки табличных данных

4)Системная программа, управляющая обработкой табличных данных

Вопрос 2. ЭТ предназначена для

1)обработки числовых данных, представленных в виде таблиц

2)упорядоченного хранения и обработки значительных массивов данных

3)визуализации структурных связей между данными, представленными в виде таблиц

4)редактирования больших объемов информации

Вопрос 3. ЭТ представляет собой

1)совокупность пронумерованных столбцов и поименованных буквами латинского языка строк

2)совокупность пронумерованных строк и поименованных буквами латинского языка столбцов

3)совокупность пронумерованных строк и столбцов

4)совокупность строк и столбцов

Вопрос 4. Строки ЭТ

1)именуются пользователем произвольным образом

2)обозначаются буквами латинского языка

3)обозначаются буквами русского языка

4)нумеруются

Вопрос 5. Столбцы ЭТ

1)обозначаются буквами русского языка

2)нумеруются

3)обозначаются буквами латинского языка

4)именуются пользователем произвольным образом

Вопрос 6. Для пользователя ячейка ЭТ идентифицируется

1)адресом машинного слова ОП, отведенного под ячейку

2)специальным кодовым словом

3)путем последовательного указания имени столбца и номера строки, на пересечении которых располагается ячейка

4)именем, задаваемым пользователем

Вопрос 7. Вычислительные формулы в ячейках ЭТ записываются

1)в обычной математической записи

2)специальным образом с использованием встроенных функций и по правилам, принятым для записи выражений в языках программирования

3)по правилам, принятым исключительно для электронных таблиц

4)по правилам математики

Вопрос 8. Выражение 3 (А1+В1) : 5 (2В1-3А2), записанное в соответствии с правилами,

принятыми в математике, в ЭТ, имеет вид

1)3* (А1+В1)/(5*(2*В1-3*А2))

2)3(А1+В1)/5*(2В1-3А2)

3)3(А1+В1)/(5*(2В1-3А2))

4)3*(А1+В1)/5*(2*В1-3*А2)

Вопрос 9. Среди приведенных отыщите формулу для ЭТ

1)А3В8+12

2)А1=А3*В8+12

3)А3*В8+12

4)=А3*В8+12

Вопрос 10. Запись формулы в ЭТ не может включать в себя

1)знаки арифметических опраций

2)числовые выражения

3)имена ячеек

4)текст

Вопрос 11. При перемещении или копировании в ЭТ абсолютные ссылки

1)не изменяются

2)преобразуются вне зависимости от нового положения формулы

3)преобразуются в зависимости от нового положения формулы

4)преобразуются в зависимости от длины формулы

Вопрос 12. При перемещении или копировании в ЭТ относительные ссылки

1)преобразуются в зависимости от нового положения формулы

2)не изменяются

3)преобразуются вне зависимости от нового положения формулы

4)преобразуются в зависимости от длины формулы

Вопрос 13. Диапазон - это

1)совокупность клеток, образующих в таблице область прямоугольной формы

2)все ячейки одной строки

3)все ячейки одного столбца

4)множество допустимых значений

Вопрос 14. Активная ячейка - это ячейка

1)для записи формул

2)для записи чисел

3)для записи чисел, формул, текста

4)в которой выполяется ввод данных

Вопрос 15. Какая Формула будет получена при копировании в E4 формулы из Е2?

1)=А2*С4

2)=А2*$С$4

3)=$А$2*С4

4)=A4*C4

Вопрос 16. Какая Формула будет получена при копировании в E4 формулы из Е2?

1)=A2*5

2)=$A$2*4

3)=A2*$C$4

4)=$A$2*5

Вопрос 17. Какая Формула будет получена при копировании в E4 формулы из Е2?

1)=$А$2*$С$4

2)=A2*$C$2

3)=$А$2*С4

4)=A4*C4

Вопрос 18. Чему будет равно значение в ячейке С1, если в нее ввести формулу =А1+В1?

1)15

2)10

3)20

4)25

Вопрос 19. Чему будет равно значение в ячейке С1, если в нее ввести формулу

=СУММ(А1:В1)*2?

1)10

2)300

3)100

4)30

Вопрос 20. Сортировкой называют

1)процесс поиска наибольшего и наименьшего элементов массива

2)процесс частичного упорядочения некоторого множества

3)любой процесс перестановки

4)процесс линейного упорядочения некоторого множества



Вы находитесь на странице вопроса "Построить формулу для определения зависимости y от x с использованием логичесикх функций и,или,если,не y=/45/", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.