Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Помогиииите! Нужно написать программу которая определяет является ли сумма цифр двухзначного числа четной

10-11 класс

Норманн 18 июля 2016 г., 22:55:21 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lilia78
19 июля 2016 г., 1:07:38 (7 лет назад)

если число не очень длинное, то можно считать в стринг. но если число длинное, то это не прокатит

 

var

q:string;

i,a,n:integer;

 

begin

readln(q):

n:=length(q);

for i:=1 to n do

a:=strtoint(q[i]);

if a mod 2 = 0 then writeln("YES) else writeln("NO");

 

end.

Ответить

Другие вопросы из категории

два текста содержат одинаковое количество символов. первый текст составлен в алфавите мощностью 16 символов. второй текст - в алфавите мощностью 256

символов. во сколько раз количество информации во втором тексте больше, чем в первом?

Помогите прошу) очень нужно, сама не знаю.

1. Укажите значения логических переменных Р, Q, S, Т, при которых логическое
выражение (Р \/ ¬Q) \/ (Q → (S \/ Т)) ложно. Ответ запишите в виде строки из четырех символов: значений переменных Р, Q, S, T (в указанном порядке).

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

СРОЧНО!!!!!!!!!!!!!!!!!!Написать программу в паскале + составить блок-схемы:

4)Если целое M делится на целое число NБ то на экран выводится частное от деления,в противном случае выводится сообщение"M на N нацело не делится".
8)Одинаковы ли цифры данного двухзначного числа.
9)является ли сумма цифр двухзначного числа четной.
12)кратна ли числу A сумма цифр двухзначного числа.
14)какая из цифр трехзначного числа больше: первая или вторая.
16) все ли цифры трехзначного числа одинаковые.

Написать программу Паскаль))) срочно!)))

Ввести с клавиатуры натуральное число.написать программу, которая определяет, кратна ли сумма его цифр 6.



Вы находитесь на странице вопроса "Помогиииите! Нужно написать программу которая определяет является ли сумма цифр двухзначного числа четной", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.