Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Имеется последовательность чисел a1, a2 , ..., aN . Найти сумму первых из них, произведение которых не превышает заданного числа М.

10-11 класс

СИ++. #include <stdio.h>
#include <stdlib.h>
#include <conio.h>

Luchkindaniil1 17 марта 2016 г., 4:47:25 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Blenthajm
17 марта 2016 г., 5:25:59 (8 лет назад)

#include <stdio.h>
#include <stdlib.h>
#include <conio.h>
#include <iostream>
using namespace std;

int main(int argc, char* argv[])
{int m;int arr[10];

cout << "input elements " << endl;
for ( int i= 0; i < 10; i++ )
cin >> arr[i];
cout << "input m " << endl;
cin >> m;
cout << "arr = {";
for ( int j = 0;j < 10; j++ )
cout << arr[j] << " ";
int sum;
for ( int k = 0; k < 10; k++ )
if (arr[k]*arr[k+1]<=m) {
sum=arr[k]+arr[k+1];break;
}
cout << "" << endl;
cout << "Summa " << " ";
cout << sum << endl;;
system("pause");
return 0;}

Ответить

Другие вопросы из категории

Построить формулу для определения зависимости y от x с использованием логичесикх функций и,или,если,не y=/45/

0<x<20,30<x<70

/x/ -10<x<0

/x-4/ 80<x<100,110<x<140,180<x

/x4/ -20<x<0

/x+2/ все остальные

Нужно написать программу в Паскале

Дан механизм,состоящий из двух шестеренок. У одной шестеренки N зубцов,у другой K. Требуется найти какое минимальное число поворотов на один зубчик требуется сделать,чтобы шестеренки вернулись в исходное состояние.

решите в паскале ABC: Вы стоите на краю дороги и от вас до ближайшего фонарного столба x метров. Расстояние между столбами y метров. На каком

расстоянии от вас находится n-й столб?

Та же ситуация, что и в предыдущей задаче. Длина вашего шага

В алфавите племени мамба есть всего 3 буквы: а, б, м, которые в текстах мамбийского языка встречаются с такой частотой: а - 60%, б - 10%, м - 30%.

Предложите самое экономное компьютерное кодирование мамбийського алфавита. Тоесть такое, что будет давать возможность хранить мамбийськи тексты с помощью наименьшего количества битов в среднем.

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА! ОЧЕНЬ НУЖНО!( 1)Осуществите циклический сдвиг компонент заданного вектора A(N) влево на одну

позицию, то есть получите вектор А = (a2 , a3 , ..., aN , a1 ).

2) Имеется последовательность чисел a1, a2 , ..., aN . Найти сумму первых из них, произведение которых не превышает заданного числа М.

СИ++. #include <stdio.h>

#include <conio.h>

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.

Дана последовательность чисел a1, a2, …, an. Требуется переставит числа в поряд-ке возрастания. Для этого сравниваются два соседних числа ai и ai+1. Если

ai>ai+1 то делается пере-становка. Так продолжается до тех пор, пока все элементы не станут расположены в порядке воз-растания. Составить алгоритм сортировки, подсчитывая при этом количество перестановок.
ПОМОГИТЕ СДЕЛАТЬ В ПАСКАЛЬ, ПРОШУ =*(

Помогите, пожалуйста. Нужно написать программу паскаль.. 7.62. Даны натуральное число n и целые числа a1, a2, a3, …a9. Найти: а) номер максимального из

чисел ai,. Если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел ai,. Если чисел с минимальным значением несколько, то должен быть найден номер первого из них;



Вы находитесь на странице вопроса "Имеется последовательность чисел a1, a2 , ..., aN . Найти сумму первых из них, произведение которых не превышает заданного числа М.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.