Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогитеее, пожалуйста. Найти в одномерном массиве элементы, сумма которых максимальна, затем удалите все элементы, предшествующие тому элементу, индекс

10-11 класс

которых наибольший из двух. (в паскале)

Sys1 09 сент. 2013 г., 11:00:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Александра0305
09 сент. 2013 г., 12:55:09 (10 лет назад)

Например так(выводит начальный массив, максимальную сумму, измененный массив).

program test;
uses crt;
var
  arr:array[1..10] of integer;
  i,j,max,maxn:integer;
begin
  randomize;
  clrscr;
  for i:=1 to 10 do
    begin
      arr[i]:=random(100);
      write(arr[i],' ');
    end;
  writeln;

  max:=arr[1]+arr[2];
  maxn:=2;

  for i:=1 to 10 do
    for j:=1 to 10 do
      if i<>j then
        if max<arr[i]+arr[j] then
          begin
            max:=arr[i]+arr[j];
            if i>j then maxn:=i else maxn:=j;
          end;

  writeln('max summ=',max);
 
  for i:=1 to 10 do
    begin
      if i<maxn then arr[i]:=0;
      write(arr[i],' ');
    end;
  readln;
end.

+ 0 -
Ernestabern
09 сент. 2013 г., 15:29:33 (10 лет назад)

Тут "элементы, сумма которых максимальна" имеется в виду сумма каких пар элементов массива максимальна? Или могут быть не только пары, но и тройки, четвертки и т.д.?

+ 0 -
Egor035
09 сент. 2013 г., 16:18:46 (10 лет назад)

нет, допустим последовательность от 1-го до 5-ти и сумма цифр "4" и "5" максимальна из всех :) вроде бы так ))))

+ 0 -
викаpro
09 сент. 2013 г., 18:30:08 (10 лет назад)

Тогда смотри мое решение

Ответить

Другие вопросы из категории

помогите

срочно по информатике
подробно

Попробуйте внести изменения в блок-схему на рисунке так, чтобы алгоритм учитывал возможность выбора нескольких элементов набора данных,

удовлетворяющих одному и тому же значению критерия поиска. Например позволял решить задачу поиска из задания 3(В журнале успеваемости учащихся со сведениями о годовых оценках требуется осуществить поиск всех отличников по информатике. Что в этой ситуации является набором данных, что- ключом поиска, что- критерием поиска?)

Читайте также

1.В произвольно заданном одномерном массиве ( случайные значения из отрезка -6 до 11 ) из 6 элементов, определить количество отрицательных, нулевых и

положитльных элементов.
2.
Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры). Обнулите значения всех элементов с нечетными индексами. Выведите значения одномерного массива в строку через пробел.

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

Написать программу по ПРОЦЕДУРАМ с массивами в языке программирования Pascal.

Алгоритм поиска номера первого из двух последовательных элементов в целочисленном массиве из 30 элементов, сумма которых максимальна (если таких пар несколько, то можно выбрать любую из них). Пишите программу целиком

Опишите на русском языке или одном из языков

программирования алгоритм поиска номера первого из двух последовательных
элементов в целочисленном массиве из 30 элементов, сумма которых максимальна
(если таких пар несколько, то можно выбрать любую из них).
Тремя способами: когда запоминается первый элемент, i бежит по второму элементу, не запоминая сумму элементов, а только номер.



Вы находитесь на странице вопроса "Помогитеее, пожалуйста. Найти в одномерном массиве элементы, сумма которых максимальна, затем удалите все элементы, предшествующие тому элементу, индекс", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.