Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Цикл с постусловием. Подсчитать кол-во цифр в введеном с клавиатуры числе х кол-во троек. Составить блок схему и программу

5-9 класс

Olegsigov 24 февр. 2014 г., 3:02:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nucha2002
24 февр. 2014 г., 4:17:15 (10 лет назад)

var

  x, count:integer;

begin

  write('x = '); readln(x);

  write('Количество троек в числе ', x, ' - ');

  while x > 0 do

  begin

    if x mod 10 = 3 then

      count := count + 1;

    x := x div 10;

  end;

  writeln(count);

end.

Ответить

Другие вопросы из категории

Решите номер 18! пожалуйста!
Вам разрешено заменять в исходном слове одну букву на другую так, чтобы получившееся слово было существительным в именительном падеже падеже.Пример:

"слоН-""слоГ". Менять местами буквы запрещено. Запишите цепочки превращений следующих слов: море................суша бант..................коса шар...................куб муха.................слон

помогите пожалуйста составить программу

Заполнить массив из 500 элементов случайными числами в интервале [0..100]. Отсортировать его по возрастанию двумя способами – методом «пузырька» и методом «быстрой сортировки» . Вывести на экран число перестановок элементов массива в том и в другом случае. Массив выводить на экран не нужно.

Читайте также

1.Какое кол-во информации получит Миша после броска кубика с 16 гранями?

2.Играя в игру "Угадай число" было получено 6 бит информации. Каково было кол-во возможных событий?
3. Маша переехала в многоэтажный дом, и сообщение о том,что она живет на 24 этаже,несет 5 бит информации.Сколько этажей в доме?

Язык программирования Бейсик Здравствуйте. Кто может найти ошибку в моем решении задачи: "Напишите программу, которая находит кол-во

чисел, кратных 3, но не кратных 6, в последовательности заданных чисел. Программа получает на вход целые числа, кол-во введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Кол-во чисел не превышает 1000. Введенные числа по модулю не превышают 30000."

Решение:

10 CLS

20 FOR I=1 TO 1000

30 INPUT "Введите число";A(I)

40 IF A(I)=0 THEN M=I AND 60

50 NEXT I

60 FOR I=1 TO M

70 IF A(I) MOD 3 = 0 AND A(I) MOD 6 <>0 THEN S=S+1

80 NEXT I

0 PRINT S

100 END

Заранее спасибо

Задачи на кол-во информации)

1. Определите информационный объем текста в кавычках. Кавычки не учитывать: "Приучайтесь думать точно!"
2. На дискете помещается 1,4 Мб информации. Сколько дискет может заменить один жесткий диск, емкостью 420 Мб?
3. Сколько необходимо памяти (в Мб), чтобы сохранить картинку, которую мы видим на экране, если про монитор известно: кол-во точек 800*1200, кол-во цветов - 521?
4. а) в следующих записях проставьте знаки отношений:
3,2 Гбайта 4000 Мб
7 байт 55 бит
8150 байт 8 Кб
б) дополните равенства
9 байтов=___битам
20 Мбайтов=___Кб
5. Информация передаётся со скоростью 3 Кб/сек. Какой объем информации будет передан за 20 минут? Ответ дать в Мб.



Вы находитесь на странице вопроса "Цикл с постусловием. Подсчитать кол-во цифр в введеном с клавиатуры числе х кол-во троек. Составить блок схему и программу", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.