Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Запишите, пожалуйста, на языке Паскаля. Условие задачи: подсчитать кол-во положительных чисел среди чисел a, b, c .

5-9 класс

Nastya75356 21 окт. 2013 г., 2:25:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kavkovakristin
21 окт. 2013 г., 4:15:18 (10 лет назад)

Program abc;

var a, b, c:real;

var i: integer;

Begin

writeln ('Введите число а');

readln (a);

writeln ('Введите число b');

readln (b)

тоже самое и для с

i:=0

if a>0 then I:=i+1

тоже самое только для б и с

writeln ('Число положительных чисел = , 'i);

End. 

 

+ 0 -
Juttfhjrdv
21 окт. 2013 г., 4:58:10 (10 лет назад)

var
a,b,c,n,i:integer;
begin
n:=0;
readln(a);
readln(b);
readln(c);

if a>0 then
n:=n+1;
if b>0 then
n:=n+1;
if c>0 then
n:=n+1;
writeln('kolichestvo polozitelnich=', n)
end.

Ответить

Читайте также

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

Пожалуйста помогите написать 3 несложных задания...

1...Записать на языке паскаля: Условие 1) -3<x<=(меньше или равно)10;
2)x (не равно 0) ,у(не равно 0);
3)x(принадлежит) [-10;0);
4)величина x не кратна 3:

2.Cоставить программу,которая находит меньшее из трёх введённых чисел a,b,c и выводит на экран.

3.Введите три числа a,b,c.Найдите сумму двух наибольших из них.

ПОМОГИТЕ ПОЖАЛУЙСТА,ОЧЕНЬ ВАЖНОЕ ЗАДАНИЕ,ОТВЕЧУ ВЗАИМНОСТЬ...)
Огромное спасибо за ранее...

Дан массив с 10 числами ( любой диапазон с отрицательными числами)

Необходимо посчитать элементы массива значения которых кратно 2. Заменить элементы массива значения которых отрицательны,заменить числом 111
Напишите программу пожалуйста на языке паскаля

Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округ

ляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км\ч, выведите YES, иначе выведите NO.

Программа получает на вход число проехавших автомобилей N (1=<N=<30), затем указывает их скорости. Значение скорости не может быть меньше 1 и больше 300.

Программа должна сначала вывести максимальную скорость, затем YES или NO.

Написать на языке Паскаль

Пример работы программы: (смотри во вложениях)



Вы находитесь на странице вопроса "Запишите, пожалуйста, на языке Паскаля. Условие задачи: подсчитать кол-во положительных чисел среди чисел a, b, c .", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.