Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль, помогите. Сделать так, чтобы программа повторилась несколько раз

5-9 класс

program z;
var x,a,k:integer;
begin
x:=random(100)+1;
repeat
writeln('Введите число от 1 до 100');
readln(a);
k:=k+1;
if a>x then write ('>');
if a<x then write ('<');
until a=x;
writeln('Вы угадали с ' ,k, '-й попытки');
end.

Kilinandrey 10 июня 2014 г., 8:26:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kedd7
10 июня 2014 г., 9:19:54 (9 лет назад)

repeat ставишь в начало, где нужно повторение
 until false в конец

Ответить

Другие вопросы из категории

Какая встроенная функция языка Паскаль,обозначается словом mod.

Приведите 2 примера выполнения функции

Читайте также

Помогите решить эти 16 вариантов, или хотя бы несколько. Что нужно сделать: Составить программу в Pascal ABC( Нужно сделать так, чтобы вы вводили

координаты х и у и программа проверяет, подходит ли эта точка к графику или нет. Пример на 2 фото.
Очень нужно. 80 баллов

Сделайте так чтобы работал Поажлуйста доброе дело пожалуйста

завтра экзамен вроде написала а не работает
не проходите мимо кто знает паскаль пожалуйстаvar integer:n; begin string:= writeln; ('Добро пожаловать в мою программу по сочетанию цветов!') if st:=Белый then n:=('сочетается со всем. Наилучшее сочетание с синим, красным и черным.') if st:=Бежевый then n:=('с голубым, коричневым, изумрудным, черным, красным, белым. ') if st:=Серый then n:=('базовый цвет, хорошо сочетается с капризными цветами: фуксия, красный, фиолетовый, розовый, синий. ') if st:=Розовый then n:=('с коричневым, белым, цветом зеленой мяты, оливковым, серым, бирюзовым, нежно - голубым. ') if st:=Фуксия (темно – розовый) then n:=('с серым, желто-коричневым, зеленым лаймом, зеленой мятой, коричневый. ') if st:=Красный then n:=('подходит к желтым, белым, бурым, зеленым, синим и черным. ') if st:=Томатно – красный then n:=(' голубой, зеленая мята, песчаный, сливочно – белый, серый. ') if st:=Вишнево-красный then n:=('лазурный, серый, светло-оранжевый, песчаный, бледно-желтый, бежевый. ') if st:=Малиново-красный then n:=('белый, черный, цвет дамасской розы. ') if st:=Коричневый then writeln('ярко-голубой, кремовый, розовый, палевый, зеленый, бежевый. ') if st:=Светло-коричневый then n:=('бледно-желтый, кремово-белый, синий, зеленый, пурпурный, красный. ') if st:=Темно-коричневый then n:=('лимонно-желтый, голубой, зеленая мята, пурпурно-розовый, зеленый лайм. ') if st:=Рыжевато-коричневый then n:=('розовый, темно-коричневый, синий, зеленый, пурпурный. ') if st:=Оранжевый then n:=('голубой, синий, лиловый, фиолетовый, белый, черный') if st:=Светло – оранжевый then n:=(' серый, коричневый, оливковый. ') if st:=Темно –оранжевый then n:=(' бледно – желтый, оливковый, коричневый, вишнёвый. ') if st:=Желтый then n:=('синий, лиловый, светло-голубой, фиолетовый, серый, черный. ') if st:=Лимонно-желтый then n:=('вишнево-красный, коричневый, синий, серый. ') if st:=Бледно-желтый then n:=('фуксия, серый, коричневый, оттенки красного, желтовато-коричневый, синий, пурпурный. ') if st:=Золотисто-желтый then n:=('серый, коричневый, лазурный, красный, черный. ') if st:=Светло – зеленый then n:=('золотисто-коричневый, коричневый, розовый, темно-оранжевый, темно-синий, серый. ') if st:=Оливковый then n:=('апельсиновый, светло-коричневый, коричневый. ') if st:=Зеленый then n:=('золотисто-коричневый, оранжевый, салатный, желтый, коричневый, серый, кремовый, черный, сливочно-белый. ') if st:=Салатный цвет then n:=('коричневый, желтовато-коричневый, палевый, серый, темно-синий, красный, серый. ') if st:=Бирюзовый then n:=('фуксия, вишнево-красный, желтый, коричневый, кремовый, темно-фиолетовый. ') if st:=Голубой then n:=('красный, серый, коричневый, оранжевый, розовый, белый, желтый. ') if st:=Темно-синий then n:=('светло-лиловый, голубой, желтовато-зеленый, коричневый, серый, бледно-желтый, оранжевый, зеленый, красный, белый. ') if st:=Лиловый then n:=('оранжевый, розовый, темно-фиолетовый, оливковый, серый, желтый, белый. ') if st:=Темно-фиолетовый then n:=('золотисто-коричневый, бледно-желтый, серый, бирюзовый, зеленая мята, светло-оранжевый. ') if st:=Черный then n:=('Черный универсален, элегантен, смотрится во всех очетаниях, лучше всего с оранжевым, розовым, салатным, белым, красным, сиреневатым или желтым.')end.

Здравствуйте, мне нужна помощь с программой Excel.

Есть программа, которая преобразует слово из трех букв в число в 32-ичной сс(русс. алф).
После этого, переводит число в 10-ую сс.
Максимум может получиться 6 цифр, минимум 3.
Мне
нужно как-то сделать так, чтобы если у меня три цифры, то добавлялось
спереди три нуля, четыре цифры-добавлялось два нуля, пять
цифр-добавлялся один ноль, шесть-не добавлялось ни одного нуля.

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА



Вы находитесь на странице вопроса "Паскаль, помогите. Сделать так, чтобы программа повторилась несколько раз", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.