Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано натуральное число. Вычислить количество цифр, являющихся степенями 3

10-11 класс

8Машуля8 11 сент. 2014 г., 11:14:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Voldemort
11 сент. 2014 г., 14:14:27 (9 лет назад)

var a,k:integer;
begin
readln(a);
k:=0;while (a<>0) do begin
  if a mod 10 in [1,3,9] then k+=1;  //3^0=1, 3^1=3, 3^2=9
  a:=a div 10;
end;
writeln(k);
end.

Ответить

Читайте также

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Помогите, пожалуйста написать программу на паскаль

Дано натуральное число. Вычислить количество цифр, являющихся степенями тройки (1,3,9).



Вы находитесь на странице вопроса "Дано натуральное число. Вычислить количество цифр, являющихся степенями 3", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.