Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пож!!! Используя оператор case, напишите пож. программу, которая переводит десятичные числа 1, 5, 10, 50, 100, 500, 1000,

5-9 класс

считываемые с клавиатуры, в римские.

Poli2506 03 апр. 2017 г., 14:31:03 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
04042002
03 апр. 2017 г., 17:09:02 (7 лет назад)

var a:integer;

s:string;

Begin

  read(a);

  case a of

    1: s:="I";

    5: s:="V";

    10: s:="X";

    50: s:="C";

    100: s:="C";

    500: s:="I";

    1000: s:="M;

  end;

  writeln(s);

End.

 

римские соответствия не все помню

Ответить

Другие вопросы из категории

Устройство ввода,используемое для управления компьютером во время игры?

Другое название жёсткого диска?

Кодирование числовой информации. 1. Перевести число из 10-тичной системы счисления в двоичную, восьмиричную и 16-ричную систему счисления: а)

635,б) 427, в) 686,6875,г) 683,5 д) 220,68

2.Перевести в 10-тичную систему счисления.

а) 1001010111( в двоичную),б) 101110100( в двоичную) в) 1001000000(в двоичную) г) 1100011101,1101( в двоичную) д) 1267,16( в восьмиричную) е) 5А,6( шеснадцатиричную)

Читайте также

1. Напишите программу, которая вводит трехзначное число и разбивает

его на цифры. Например, при вводе числа 123 программа должна
вывести 1, 2, 3.
2. Напишите программу, которая вводит возраст человека (число, не
превосходящее 120) и выводит на экран этот возраст со словом «»год,
«года» , «лет» . например «21 год», «22 года», «15 лет»

Помогите пожалуйста !!!!

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

1)напишите программу которая спрашивала бы название продукта и его цену. И затем на экран выводила фразу "Ваши расходы на покупки равны руб." 2) написать

программу, которая запрашивала три числа, подсчитывала их средне и сумму и на экран выводила фразу "Их среднее равно..." и "Их сумма равна..."



Вы находитесь на странице вопроса "Помогите пож!!! Используя оператор case, напишите пож. программу, которая переводит десятичные числа 1, 5, 10, 50, 100, 500, 1000,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.