Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Из семи красных и восьми белых роз требуется составить букет из пяти роз. Перечислить все возможные варианты

10-11 класс

Avpiskunow 02 дек. 2013 г., 22:04:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dfcbkbcf2003
03 дек. 2013 г., 0:31:21 (10 лет назад)

uses crt; 

+ 0 -
Kristi1617
03 дек. 2013 г., 3:02:36 (10 лет назад)

var
  x: byte;
  y: string;

begin
  for x := 0 to 31 do
  begin
    y := System.Convert.ToString(x, 2);
    y := new string('0', 5 - y.Length) + y;
    y := y.Replace('0', 'Б').Replace('1', 'К');
    writeln(y);
  end;
end.

БББББ
ББББК
БББКБ
БББКК
ББКББ
ББКБК
ББККБ
ББККК
БКБББ
БКББК
БКБКБ
БКБКК
БККББ
БККБК
БКККБ
БКККК
КББББ
КБББК
КББКБ
КББКК
КБКББ
КБКБК
КБККБ
КБККК
ККБББ
ККББК
ККБКБ
ККБКК
КККББ
КККБК
ККККБ
ККККК

Ответить

Читайте также

Поле шахматной доски представляется парой натуральных чисел, каждое из которых не превосходит восьми: первое число - номер вертикали (при счете снизу

вверх), второе - номер горизонтали (при счете слева направо). Даны натуральные числа k, l, m,n, каждое из которых не превосходит восьми. Требуется:

1. выяснить, являются ли поля (k, l) и (m, n) полями одного цвета

2. на поле (k, l) расположен ферзь. Угрожает ли он полю (m, n)?

задача в Delphi.

1).

На одном из секретных заводов осуществляется обработка радиоактивных материалов, в результате которой образуются радиоактивные отходы двух типов: типа A — особо опасные и типа B — неопасные. Все отходы упаковываются в специальные прямоугольные контейнеры одинаковых размеров, после чего эти контейнеры укладываются в стопку (один над другим) для захоронения. Стопка является взрывоопасной, если в ней подряд идут более чем два контейнера с отходами типа A.

Требуется написать программу, которая подсчитывает количество возможных вариантов формирования взрывоопасной стопки для заданного числа контейнеров N.

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива



Вы находитесь на странице вопроса "Из семи красных и восьми белых роз требуется составить букет из пяти роз. Перечислить все возможные варианты", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.