Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать программу нахождения треугольника .Значения сторон вводятся с клавиатуры.

5-9 класс

Ольга124 05 февр. 2017 г., 9:47:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Санек46
05 февр. 2017 г., 10:18:51 (7 лет назад)

нахождения треугольника чего? периметра? площади? углов?

 

var

a, b, c, p, s, pp: real;
begin
write('vvedite storony');
read(a,b,c);
p:=a+b+c;
pp:=p/2;
s:=sqrt(pp*(pp-a)*(pp-b)*(pp-c));
if (a+b<=c) or (a+c<=b) or (b+c<=a) then
writeln('treugolnik ne syschestvuet')
else
begin
writeln('p=',p);
writeln('s=',s);
end;

end.

Ответить

Другие вопросы из категории

Компьютерная распределённая система для получения

информации о доменах. Чаще всего используется для получения IP-
адреса по имени хоста (компьютера или устройства), получения
информации о маршрутизации почты, обслуживающих узлах для
протоколов в домене и называется:
1) UDP (User Datagram Protocol);
2) SPF (Sender Policy Framework);
3) DNS (Domain Name System);
4) DKIM (Domain Keys Identified Mail).

Читайте также

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

Помогите, пожалуйста, написать программу в Паскаль

Напечатать таблицу перевода 1,2,…, 20 долларов США в рубли по текущему курсу (значение курса вводится с клавиатуры).

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"



Вы находитесь на странице вопроса "написать программу нахождения треугольника .Значения сторон вводятся с клавиатуры.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.