Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны три действительных числа. Если только два из них равны между собой, то возвести все числа в квадрат и напечатать в противном случае напечатать все

10-11 класс

три числа. Написать программу

Snezhka20021 14 февр. 2017 г., 11:40:35 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Morozdarina201
14 февр. 2017 г., 13:06:04 (7 лет назад)

var
  a, b, c : real;
begin
  read (a, b, c);
  if (a = b) xor (b = c) xor (a = c) then // если только одно из равенств верно
  write (sqr (a), ' ', sqr (b), ' ', sqr (c))
  else write (a, ' ', b, ' ', c);
end.

Ответить

Другие вопросы из категории

Помогите пожалуйстааа

Если можно, то скажите почему именно этот ответ)

написать программу на языке Паскаля . Заданы координаты двух точек. Определите, расположены ли они на одной окружности с центром в начале координат.

Результат присвоить символьной переменной. Две точки находятся на одной окружности, если длины радиус-векторов, соединяющих эти точки с началом координат, равны (проверку на равенство осуществить с точностью до е=1.0Е-3)

1) Заполнить массив по следующему принципу:

6 7 18 19 30 31
5 8 17 20 29 32
4 9 16 21 28 33
3 10 15 22 27 34
2 11 14 23 26 35
1 12 13 24 25 36

Читайте также

Даны три действительных числа. Выбрать

из них те, которые принадлежат интервалу
(1, 3).

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то

вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.



Вы находитесь на странице вопроса "Даны три действительных числа. Если только два из них равны между собой, то возвести все числа в квадрат и напечатать в противном случае напечатать все", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.