Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

составить программу в Паскале Массив A(M,N) заполнить случайными числами из промежутка [-15;-8] и подсчитать произведение элементов чётных

10-11 класс

строк.Исходный массив и результат вывести на экран

варп 12 нояб. 2013 г., 16:05:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gandzhina1
12 нояб. 2013 г., 18:10:35 (10 лет назад)

Вместо 20 можно подставить любое число, 20 соответствует M,N

program new;
var a:array [1..20,1..20] of integer; i,j,sum:integer;
begin
randomize;
for i=1 to 20 do
begin
for j=1 to 20 do
begin
a[i,j]:=random(8)-15
end;
end;
for i=2 to 20 do
begin
for j=1 to 20 do
begin
sum:=sum+a[i,j];
i:=i+2;
end;
end;
for i=1 to 20 do
begin
for j=1 to 20 do
begin
write(a[i,j]);
end;
writeln;
end;
writeln('Сумма равна ',sum:8);
end.

P.S.
Делал без паскаля если какие то ошибки то пиши

Ответить

Другие вопросы из категории

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Составить программу в паскале по подсчету кол-ва претендентов, которые попадут в школьную баскетбольную команду,если рост игрока должен быть не менее

170 см. Считать число претендентов случайном числом в диапазоне от 150 до 200, число претендентов 50 (программу писать через массив)

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Помогите плиз написать программы на Паскале)))

1.Составьте программу, проверяющую, верно ли
утверждение, что введенное вами целое число является четным.
2.



Вы находитесь на странице вопроса "составить программу в Паскале Массив A(M,N) заполнить случайными числами из промежутка [-15;-8] и подсчитать произведение элементов чётных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.