Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

В библиотеке

5-9 класс

имеются 200 тысяч книг по 100 страниц и по 3 тысячи знаков на странице в
среднем. Какое количество информации хранится в библиотеке?

Ответ запишите в
байтах, Кбайтах, Мбайтах.

Sonyaosieva 21 сент. 2014 г., 10:27:18 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Polynka202
21 сент. 2014 г., 11:20:14 (9 лет назад)

200*10^3\ *\ 100\ *\ 3*10^3=60000000000bytes
60000000000/1024=58593750KiB
58593750/1024=57220,458984375MeB

Ответить

Другие вопросы из категории

ЛЮДИ ПОМОГИТЕ ПОЖАЛУЙСТА!!!! Это тема :простые и составные условия,команда ветвление(паскаль)

составьте программу ,определяющую, является ли целое положительное число трехзначным

Одной из задач, возникающей при разработке поисковых систем, является поиск самых популярных сайтов по ключевым словам (тегам), описывающим сайт. Дан

список сайтов. Про каждый сайт известны набор тегов сайта и его популярность. Есть запрос в виде набора тегов. На запрос необходимо выдать самый популярный сайт, у которого в описании встречаются все теги из запроса.
Формат входного файла

В первой строке входного файла input.txt находится набор тегов, разделённых ровно одним пробелом, количество тегов не превосходит 5. Тегом назовём такую строку, которая содержит только строчные латинские буквы и ее длина не превосходит 10 символов. В следующей строке дано число N (1 ≤ N ≤ 20)— количество сайтов.

Каждый сайт описывается тремя строками. В первой строке название сайта. Название сайта состоит только из строчных латинских букв и точки. Длина названия сайта не превосходит 15 символов. Во второй строке набор тегов сайта, разделенных пробелами. Количество тегов не превосходит 10. В третьей строке число Ai(1 ≤ Ai ≤ 1000000)— популярность сайта.
Формат выходного файла

В выходной файл output.txt требуется вывести любой самый популярный сайт, у которых встречаются все теги из запроса. Гарантируется, что найдётся, хотя бы один сайт отвечающий запросу.
Пример входных и выходных данных

Input.txt
football volleyball
5
sportbox.ru
sport football volleyball basketball swimming hockey
5000
championat.com
sport football volleyball basketball hockey
4000
soccer.ru
sport football
6000
sport.ru
sport football vоlleyball
1000
sports.ru
sport football volleyball basketball swimming hockey
2000

Output.txt

sportbox.ru

Я задачу решила, на мои тесты работает.

Однако, когда я отправляю ее тестировать на сайт, вылезает что программа выдала неправильный ответ.

program Project2;

{$APPTYPE CONSOLE}

uses
SysUtils;

var
s,r:string;
tegs,sait,d,x1:array[1..255] of string;
pop,l,x:array[1..100000] of integer;
i,j,k,n,f,max,max1:integer;
begin
assign(input,'Input.txt');reset(input);
assign(output,'Output.txt');rewrite(output);
readln(s);s:=s+' ';f:=0;
for i:= 1 to length(s) do begin
if s[i]<>' ' then r:=r+s[i];
if s[i]=' ' then begin k:=k+1;d[k]:=r;r:='';end;
end;
readln(n);
for i:= 1 to n do begin
readln(sait[i]);
readln(tegs[i]);
readln(pop[i]);
end;
for i:= 1 to n do begin
for j:= 1 to k do begin
if pos(d[j],tegs[i])<>0 then f:=f+1;
end;
l[i]:=f;
f:=0;
end;
max:=0;max1:=0;
f:=0;
for i:=1 to n do
if l[i]>max then max:=l[i];
for i:=1 to n do
if l[i]=max then begin inc(f);x[f]:=pop[i];x1[f]:=sait[i];end;
for i:=1 to f do
if x[i]>max1 then begin max:=x[i];k:=i;end;
writeln(x1[k]);
close(input);close(output);
end.

Читайте также

Разработайте меню, которое может быть в программе автоматического поиска книги в библиотеке. В вашемменю должно быть не четырёх уровней. Меню каждого

уровня поместите в отдельные прямоугольники.соедените линиями пункты меню и связанные с ними меню следующего уровня.
При разработке меню можно исползовать следующие понятия: библиотека; роман; С. Я. Маршак; А. Л. Барто; русский язык; иностранный язык; литература; рассказ; словарь; справочник; стихотворение;сказка ;фантастика; художественная литература; математика; братья Гримм; Н. А. Некрасов; учебник; специальная литература; история; английский язык; М. Ю. Лермантов; немецкий язык; естествознание; французский язык ; Г. Х. Андерсен; А. С .Пушкин; А. Линдгрен; география; Дж. Родари; информатика.

Каждый из 35 шестиклассников является читателем по крайней мере одной из двух библиотек:школьной и районной.Из них 25 человек берут книги в школьной

библиотеке,20 в районной. 1)не читатели школьной библ-ки?2)не читатели районной библ-ки?3)читатели обеих библ-к?4)читатели только районной библ-ки?5)читатели только школьной библ-ки?

Запишите команды для выполнения следующих действий с БД «Домашняя библиотека»;

а) сортировки в порядке возрастания годов издания книги;
б) сортировки по двум ключам: АВТОР и ГОД, исключая книги Беляева А.Р.;
в) удаления из БД «Домашняя библиотека» всех записей о книгах, стоящих на пятой полке и изданных до 1990 года.

каждый из семиклассников является читателем, по крайней мере, одной из двух библиотек: школьной и районной. из них 25 человек бурут книги в школьной

библиотеке а 20 в районной. сколько семиклассников являются читателями обеих библиотек? ответ поясните и проиллюстрируйте

меню в программе автоматического поиска книги в библиотеке.можно использовать следующие

понятия:библиотека,роман,С.Я.Маршак,А.Л.Барто,русский язык.литература,рассказ,словарь,справочник,стихотворение,сказка,фантастика,удожественная литература,математика,братья Гримм,Н.А.Никрасов,учебник,специальная литература,история,английский язык,М.Ю.Лермонтов,немецкий язык,естествознание,французский язык,Г.Х.Андерсен,А.С.Пушкин,А.Линдгрен,гелграфия,Дж.Родари,информатика.



Вы находитесь на странице вопроса "В библиотеке", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.