Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задача в паскале.

10-11 класс

Вывести на экран в порядке возрастания все цифры, не являющиеся цифрами данного десятичного натурального числа (переменной целого

Novikova01 18 июня 2014 г., 5:04:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elenuska
18 июня 2014 г., 7:53:01 (9 лет назад)

var
    s: string;
    i, n: integer;
    c: char;
    b:boolean;

begin
    readln(n);
    s := inttostr(n);
    for c := '0' to '9' do
    begin
        b := true;
        for i := 1 to length(s) do
            if s[i] = c then begin
                b := false;
                break;
            end;
        if b then writeln(c);
    end;
   
end.

+ 0 -
Parry14
18 июня 2014 г., 9:26:46 (9 лет назад)

Это что так срочно?

+ 0 -
богдан4
18 июня 2014 г., 10:27:10 (9 лет назад)

нет.

+ 0 -
Юлианусик
18 июня 2014 г., 12:50:45 (9 лет назад)

самое простое - преобразовать в строку и дольше работать с фунцкцией поиска подстроки.

Ответить

Другие вопросы из категории

Написать программу в Паскале.

Указания: Заполните одномерный числовой массив А[15] случайными целыми числами в интервале [18;15].Выведите значения элементов массива сначала в столбик,а затем в строку,причем на каждый элемент отведите 4 позиции.
Задача: Заменить элементы массива,которые кратны пяти,на значение максимального элемента массива.

Читайте также

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:

Решить задачу в Паскале:

Задать случайным образом 8
элементов числового массива – числа от 100 до 200. Вставить в него:

а) число «-20» перед 5-ым
элементом.

б) число «0» перед максимальным элементом. В одной задаче должно быть и а и б (но можно и по отдельности, главное, чтобы было верно)))

Нужно решить задачу в Паскале, условие таково:

"Найти наименьшее кратное двух чисел a и b"

Насколько я помню в этой задаче можно использовать команду Break.


Здравствуйте) помогите составить задачи по паскалю)

задачи на такую тему: Составление, ввод, трансляция и
исполнение программ, реализующих
циклические алгоритмы и типовые
операции с одномерными массивами

Помогите решить задачу на Паскале.

Дана строка.Перенести последнюю букву слова в начало слова



Вы находитесь на странице вопроса "Задача в паскале.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.