Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Ребят, помогите,пожалуйста,очень срочно!!! найти сумму положительных элементов массива а(15) ПАСКАЛЬ, 10 КЛАСС ШКОЛЬНЫЙ УРОВЕНЬ, БЕЗ ВСЯКИХ ОСЛО

10-11 класс

ЖНЕНИЙ! СПАСИБО!

НарминаАсланова 08 июня 2014 г., 14:47:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tiholazpolia
08 июня 2014 г., 17:09:42 (9 лет назад)

Program Program1;
Var
a:array [1..15] of integer;
i,sum:integer;
begin
randomize;
for i:=1 to 15 do
begin
a[i]:=random(100)-50;
writeln('a['+inttostr(i)+']= '+inttostr(a[i]));
end;
sum:=0;
for i:=1 to 15 do
if a[i]>0 then sum:=sum+a[i];
writeln('Cумма положительных элементов массива = '+inttostr(sum));
end.

Ответить

Другие вопросы из категории

Написать программу в Паскале.

Указания: Заполните одномерный числовой массив А[15] случайными целыми числами в интервале [18;15].Выведите значения элементов массива сначала в столбик,а затем в строку,причем на каждый элемент отведите 4 позиции.
Задача: Заменить элементы массива,которые кратны пяти,на значение максимального элемента массива.

Читайте также

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

Вычислите среднее арифметическое число положительных элементов массива A(N1), B(N2), C(N3)

Помогите пожалуйста очень срочно надо))), заранее спасибо)))

Помогите пожалуйста, очень срочно!

Дан массив А , содержащий N элементов .Найти произведение отрицательных элементов массива и их количество. Нарисовать блок-схему. Просчитать значения: N=10 , массив А={-2;0;10;-1;7;3;0}

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.



Вы находитесь на странице вопроса "Ребят, помогите,пожалуйста,очень срочно!!! найти сумму положительных элементов массива а(15) ПАСКАЛЬ, 10 КЛАСС ШКОЛЬНЫЙ УРОВЕНЬ, БЕЗ ВСЯКИХ ОСЛО", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.