Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

в С++ кто-нибудь работает здесь?? помогите! 1. написать функцию произведения 3-х последних цифр любого числа, содержащего более 3-х

10-11 класс

знаков. Если меньше, то сообщить

ALBINA19751 23 окт. 2014 г., 11:26:18 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dinar526
23 окт. 2014 г., 12:08:33 (9 лет назад)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

void test(int);

int main()
{
   int number;

   cout << "Enter the number: ";
   cin >> number;

   if(number < 1000)
   {
      cout << "Error" << endl;
   }
   else
      test(number);

   return 0;
}

void test(int number)
{
   int a, b, c;

   c = number % 10;
   number /= 10;

   b = number % 10;
   number /= 10;

   a = number % 10;

   cout << a << " * " << b << " * " << c << " = " << (a * b *c) << endl;
}

Ответить

Другие вопросы из категории

Решить задачи:

Задача 1. Составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы.

В коробке 30 одинаковых юбилейных монет. Известно, что 5 из них имеют нестандартный процент содержания золота. Случайным образом выбирают три

монеты. Вычислите вероятность того, что:
а) все монеты имеют нестандартный процент содержания золота;
б) только одна монета имеет нестандартный процент содержания золота.

Читайте также

Прошу вас помогите!Нужно написать программу,но только обязательно в Visual Basic!!!!!

На вход программе подаются сведения о
телефонах всех сотрудников некоторого учреждения. В первой строке
сообщается количество сотрудников N, каждая из следующих N строк имеет
следующий формат:

<Фамилия> <Инициалы> <телефон>

где <Фамилия> – строка, состоящая не более чем из 20 символов, <Инициалы> - строка, состоящая не более чем из 4-х символов (буква, точка, буква, точка), <телефон> – семизначный номер, 3-я и 4, я, а также 5-я и 6-я цифры которого разделены символом «–». <Фамилия> и <Инициалы>, а также <Инициалы <телефон> разделены одним пробелом. Пример входной строки:

Иванов П.С. 555-66-77

Сотрудники
одного подразделения имеют один и тот же номер телефона. Номера
телефонов в учреждении отличаются только двумя последними цифрами.
Требуется написать как можно более эффективную программу, которая будет
выводить на экран информацию, сколько в среднем сотрудников работает в
одном подразделении данного учреждения.


СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО, УМОЛЯЮ, ТОЛЬКО ПРАВИЛЬНО!!!Я

УЖЕ 20 РАЗ ЭТО ЗАДАНИЕ ПОСЫЛАЮ, НАПИШИТЕ!!! КТО СМОЖЕТ, ТОЛЬКО ПРАВИЛЬНО!

СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО,

УМОЛЯЮ, ТОЛЬКО ПРАВИЛЬНО!!!Я УЖЕ 30 РАЗ ЭТО ЗАДАНИЕ ПОСЫЛАЮ, НАПИШИТЕ!!! КТО СМОЖЕТ, ТОЛЬКО ПРАВИЛЬНО! КТО, ЧТО СМОЖЕТ, НО НАДО ВСЕ, НА ЗАВТРА!!!



Вы находитесь на странице вопроса "в С++ кто-нибудь работает здесь?? помогите! 1. написать функцию произведения 3-х последних цифр любого числа, содержащего более 3-х", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.