Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

дан вектор b[1:10] а)найти минимальный и максимальный элементы вектора.,)поменять местами максимальный и минимальный элементы. в)получить сумму

10-11 класс

элементов между их номерами.г)Получить произведение отрицательных элементов. Помогите пожалуйста.

чеLoveчекКристи 27 февр. 2015 г., 23:44:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikaliaska78
28 февр. 2015 г., 2:37:10 (9 лет назад)

uses crt;
var b:array [1..10] of real;
    min,max,x:integer;
    sum,pr,t:real;
begin
     sum:=0; pr:=1;
     for x:=1 to 10 do
     begin
          write('b[',x,']:'); readln(b[x]);
     end;
     min:=1; max:=1;
     for x:=1 to 10 do
     begin
         if b[x]<b[min] then min:=x;
         if b[x]>b[max] then max:=x;
     end;
     t:=b[min];
     b[min]:=b[max];
     b[max]:=t;
     if max>=min then
     for x:=min+1 to max-1 do
         sum:=sum+b[x]
     else
     for x:=max+1 to min-1 do
         sum:=sum+b[x];
     for x:=1 to 10 do
         if b[x]<0 then pr:=pr*b[x];
     for x:=1 to 10 do
         write(b[x],' ');
     writeln; writeln(sum);
     writeln(pr);
end.    

+ 0 -
Mega1234
28 февр. 2015 г., 4:09:32 (9 лет назад)

вектор в смысле массив?

+ 0 -
ДАРЬЮШКА43
28 февр. 2015 г., 6:56:08 (9 лет назад)

Да

Ответить

Другие вопросы из категории

Написать программу проверки знания истории архитектуры. Программа должна вывести вопроси три варианта ответа. Пользователь должен выбрать

правильный ответ и ввести его номер.Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).
Архитектор Исаакиевского собора:
1. Доменико Трезини
2. Огюст Монферран
3. Карл Росси
Введите номер правильного ответа и нажмите <Enter>
= 2
Правильно.
Архитектор Исаакиевского собора - Огюст Монферран

на языке Turbo Pascal

решите задание в delphi 7 (бред не пишите плз)(без массива)

группа студентов сдает экзамен. оценки формируются случайным образом от 2 до 5. Напечатать кол-во полученых двок, трок, четверок, пятерок

Основные виды сетевых топологий:

шинная;
кольцевая;
линеиная;
звездообразная.


1) все перечисленные, кроме "кольцевая"

2) все перечисленные, кроме "шинная"

3) все перечисленные

4) все перечисленные, кроме "звездообразная"

5) все перечисленные, кроме "линейная"

Объяснить, что означает каждая строчка: Program sum_mas; uses Crt; Var i: integer; sum:real; M:array[1..5]

of Real;

begin

WriteLn('Введите число m[',i,']=');

readln(m[i]);

end;

Sum:=0;

For i:=1 to 5 do

Sum:=sum+m[i];

Writeln('сумма =',sum);

readln;

end.

Читайте также

составить программу. 1)дан массив х(1..10) получить новый массив у(1..10) такой что в нем сначала идут положительные числа, нулевые

,отрицательные.(из х массива) 2)найти минимальный элемент массива х(1..10)и максимальный элемент массива.поменять их местами и вывод результирующего массива на экран

Заполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [10;10] и вывести ее на экран.

Удвоить все элементы матрицы и вывести ее на экран.
Найти минимальные и максимальные элементы в матрице, указать номера.
Просто матрица и удвоенная есть. Теперь нужно найти мин. и макс. значения

program ff;
uses crt;
const n=8;
m= 5;
var a:array [1..n, 1..m] of integer;
i,j:integer;
begin
writeln ('Матрица:');
for i:=1 to 8 do begin
for j:=1 to 5 do begin a[i,j]:=-10+random(21);
write(a[i,j]:4);
end;
writeln;
end;

for i:=1 to 8 do
for j:=1 to 5 do
a[i,j]:=a[i,j]*2;
writeln ('Удвоенная матрица:');
for i:=1 to 8 do begin
for j:=1 to 5 dowrite(a[i,j]:4);
writeln;
end;
end.

помогите пожалуста очень надо.

найти минимальний и максимальний элемент массива А[1...10] и поменять их местами

Здравствуйте. Помогите решить эту задачу в Pascal:

Найти минимальный среди максимальных элементов каждого из столбцов матриц С(5,10) и D(10,20). Задачу решить с использованием подпрограммы.

1)Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов. Использовать три процедуры (заполнение, смена, вывод).



Вы находитесь на странице вопроса "дан вектор b[1:10] а)найти минимальный и максимальный элементы вектора.,)поменять местами максимальный и минимальный элементы. в)получить сумму", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.