Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан целосисленный массив u из 25 элементов. Определить кол-во четных и не четных элементов в массиве

10-11 класс

максссссс 06 июля 2013 г., 8:57:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
LizON2002
06 июля 2013 г., 10:22:52 (10 лет назад)

var
  i,c,n:integer;
  u:array[1..25]of integer;
begin
writeln('Массив u:');
for i:=1 to 25 do
  begin
  u[i]:=random(10);
  write(u[i],' ');
  if u[i] mod 2=0 then c:=c+1 else n:=n+1;
  end;
writeln;
writeln('Четных: ',c);
writeln('Нечетных: ',n);
end.

+ 0 -
Alenchik16alenchik
06 июля 2013 г., 12:18:42 (10 лет назад)

Смотри в чём суть: 
    1.Перебираем циклом элементы массива.
    2.Если элемент массива чётный (проверяем остатком от деления на 2), то записываем в переменную в которой находится количество чётных элементов.
    3.Также с нечётными.

Надеюсь понятно.

↓↓Простой, достаточно понятно комментируемый, php код ↓↓

<?php
$array = range(1, 25); //Создаём массив с 25 элементами

Ответить

Другие вопросы из категории

Написать программу, которая для случайно введенных с клавиатуры числе а, в, с выполняет действия:

а) Четные числа делит на 2 и результат выводит на экран
б) нечетные числа выводит на экран без изменений

Помогите решить (во вложениях)

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

1.В произвольно заданном одномерном массиве ( случайные значения из отрезка -6 до 11 ) из 6 элементов, определить количество отрицательных, нулевых и

положитльных элементов.
2.
Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры). Обнулите значения всех элементов с нечетными индексами. Выведите значения одномерного массива в строку через пробел.



Вы находитесь на странице вопроса "Дан целосисленный массив u из 25 элементов. Определить кол-во четных и не четных элементов в массиве", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.