Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Напишите программу, которая в последовательности натуральных чисел подсчитывает количество чисел, заканчивающихся на 2. Программа получает на вход

5-9 класс

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, заканчивающееся на 2. Количество введенных чисел не превышает 1000, сами числа не превышают 30000.

Marussia31012001 06 февр. 2014 г., 12:49:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jaguar99
06 февр. 2014 г., 15:33:16 (10 лет назад)

var a,k,i,n:integer;
begin
readln(n);
for i:=1 to n do begin
read(a);
if a mod 10 = 2 then k+=1;
end;
writeln(k);
end.

+ 0 -
Fayan
06 февр. 2014 г., 16:06:11 (10 лет назад)

var k,a,n,i: integer;
bedin
k:=0;
readln(n);
for i:=1 to n do
begin
readln(a);
if (a mod 2 =0) and (a mod 10=2) then k:=k+1;
end;
writeln(k);
end.

Ответить

Другие вопросы из категории

Плиииз людяшеньки, помогите)))Кондитерская фабрика представилаКондитерская фабрика представила спрос на пироги с различной начинкой за три

месяца(май, июнь, июль) в виде гистограммы. Определите среднее значение спроса на пироги с той начинкой, популярность которых неуклонно росла из месяца в месяц

Читайте также

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

хееееееееелп ми!!!ПАСКАЛЬ, Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, сумма единиц и десятков

кратна 3. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 7 . Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, делящееся нацело на 7.
Количество чисел не превышает 1000. Введеные числа не превышают 30 000.
программа должна вывести одно число - минимальное число, делящееся нацело на 7.
Завтра Гиа помогите!!!

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел

в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – количество чисел, кратных 4.



Вы находитесь на странице вопроса "Напишите программу, которая в последовательности натуральных чисел подсчитывает количество чисел, заканчивающихся на 2. Программа получает на вход", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.