Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

написать программу нахождения большего и меньшего из 3 чисел помогите пожалуйстаааааааааа((((

5-9 класс

Kostja1803 27 янв. 2014 г., 15:01:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Skrillex0506164786
27 янв. 2014 г., 15:33:21 (10 лет назад)

var a,b,c:integer;
begin
readln(a,b,c);
if (a>b) and (a>c) and (b>c) then writeln('c=',c,'a=',a) else
if (b>a) and (b>c) and (a>c) then writeln('c=',c,a,'b=',b) else
if (c>a) and (c>b) and (b>a) then writeln('a=',a,'c=',c) else
if (a>b) and (a>c) and (c>b) then writeln('b=',b,'a=',a) else
if (b>a) and (b>c) and (c>a) then writeln('a=',a,'b=',b) else
if (c>a) and (c>b) and (a>b) then writeln('b=',b,'c=',c) else
readln;
end

+ 0 -
Zybnik
27 янв. 2014 г., 16:19:57 (10 лет назад)

var 

  a, b, c: real;

 

begin

  writeln('Введите 3 любых числа');

  readln(a, b, c);

  if (a < b) and (a < c) then writeln(a, ' - наименьшее число');

  if (b < a) and (b < c) then writeln(b, ' - наименьшее число');

  if (c < a) and (c < b) then writeln(c, ' - наименьшее число');

  if (a > b) and (a > c) then writeln(a, ' - наибольшее число');

  if (b > a) and (b > c) then writeln(b, ' - наибольшее число');

  if (c > a) and (c > b) then writeln(c, ' - наибольшее число');

  readln; //Убрать если среда разработки не Turbo Pascal

end.

Ответить

Другие вопросы из категории

Плиииз людяшеньки, помогите)))Кондитерская фабрика представилаКондитерская фабрика представила спрос на пироги с различной начинкой за три

месяца(май, июнь, июль) в виде гистограммы. Определите среднее значение спроса на пироги с той начинкой, популярность которых неуклонно росла из месяца в месяц

Читайте также

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

ЯЗЫК QBASIC !!! Решите задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности

положительных чисел, которые вводятся с клавиатуры. 2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).



Вы находитесь на странице вопроса "написать программу нахождения большего и меньшего из 3 чисел помогите пожалуйстаааааааааа((((", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.