Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль

10-11 класс

Составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями.

Katylik 22 янв. 2017 г., 6:03:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
удвч
22 янв. 2017 г., 8:18:23 (7 лет назад)

var

  a: array [1..10] of integer; //Инициализируем массив из 10 целых чисел

  i: integer;

begin

  for i:= 1 to 10 do

  begin

    a[i]:= random(19) + 1; //Заполняем массив случайными числами от 1 до 20

    if a[i] mod 2 = 1 then write(a[i], '  '); {Если очередной элемент массива нечетный, то он выводится}

  end;

end.

Ответить

Другие вопросы из категории

Что будет выведено на экран после выполнения фрагмента программы:

begin
a:=1; b:=2;
if (a>=1) and (b>=2) then n:=a+b else n:=a-b;
writeln ( n );
end.

Каждая

буква шифруется двузначным или трехзначным числом, в зависимости от того
гласная она или согласная (при этом неясно двузначным кодом шифруются гласные
или согласные буквы). Буквы е и ё объединены. Среди слов "крейсер",
"уловка", "шалаш", "электричество",
"преподаватель", "молоко" есть слова, зашифрованные
следующими последовательностями: 2732101263310132, 391002810039,
104281032127100, 291032810327103. Каким кодом будет зашифровано слово «роутер»?

Задан фрагмент алгоритма

если a>b
то c=a-b
иначе c=a+b
d=1
пока c<a
нц
d=d+1
c=c+1
кц
все
Нарисовать блог-схему, и определить какие значения примут переменные "c" и "d" в результате выполнения данного фрагмента алгоритма с начальными значениями a=5, b=3

помогите пожалуйста,срочно надо

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "Паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.