Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

прошу!!!!!срочно надо!!!ну приииииз!!!! это надо сделать в паскале! пожалуйста!кто нибудь!!!SOS!!!!!!

10-11 класс

Задача на строки. в предложении все сочетания символов "ух" или "Ух" заменит на "ах". Посчитать количество слов в предложении.

Юлиранда 04 марта 2017 г., 10:04:37 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rustam555
04 марта 2017 г., 12:54:23 (7 лет назад)

Будем считать, что слова могут разделяться не менее, чем одним пробелом. тогда, если учитывать только один пробел между словами, например первый, количество слов будет на единице больше количества учтенных пробелов.

var
  s: string;
  c: char;
  i, l, kb: integer;
  flag: boolean;

begin
  Writeln('Введите предложение.'); Readln(s);
  s := Trim(s); { на всякий случай удаляем начальные и конечные пробелы }
  l := Length(s);
  kb := 1; flag := false;
  for i := 1 to l do
    case s[i] of
      ' ': if (not flag) then begin flag := true; kb := kb + 1 end;
      'у', 'У': begin if (i < l) then if s[i + 1] = 'х' then s[i] := 'а'; flag := false end;
    else flag := false
    end;
  Writeln('Измененное предложение.'); Writeln(s);
  Writeln('Количество слов в предложении равно ', kb)
end.

Тестовое решение.
Введите предложение.
   Ух    ты, ах   ты, все          мы    космонавты! Эй.    дубинушка, ухнем! 
Измененное предложение.
ах    ты, ах   ты, все          мы    космонавты! Эй.    дубинушка, ахнем!
Количество слов в предложении равно 10


+ 0 -
Mary3way
04 марта 2017 г., 14:04:28 (7 лет назад)

огромное спасибо

Ответить

Другие вопросы из категории

Паскаль

Составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями.

Что будет выведено на экран после выполнения фрагмента программы:

begin
a:=1; b:=2;
if (a>=1) and (b>=2) then n:=a+b else n:=a-b;
writeln ( n );
end.

Каждая

буква шифруется двузначным или трехзначным числом, в зависимости от того
гласная она или согласная (при этом неясно двузначным кодом шифруются гласные
или согласные буквы). Буквы е и ё объединены. Среди слов "крейсер",
"уловка", "шалаш", "электричество",
"преподаватель", "молоко" есть слова, зашифрованные
следующими последовательностями: 2732101263310132, 391002810039,
104281032127100, 291032810327103. Каким кодом будет зашифровано слово «роутер»?

Читайте также

Петя, Вася и Маша остались дома одни. Кто-то из них ел варенье. На вопрос мамы, кто это сделал, они сказали:

а) Петя: "Я не ел. Маша тоже не ела."
б) Вася: "Маша действительно не ела. Это сделал Петя"
в) Маша: "Вася врет. Это он съел."

Выясните, кто ел варенье, если известно, что двое из них оба раза сказали правду, а третий один раз соврал, а один раз сказал правду.(Если можно, то с помощью лог. формулы или таблицы, пожалуйста)

Из 16-ти чисел, спросите у пользователя ,сколько нужно проанализировать чисел, а затем запросите эти числа и сделайте для каждого вывод, является ли

оно четным или отрицательным.(Паскаль)

Или так: Из 16 -ти чисел,сделайте для каждого вывод,является ли оно четным или отрицательным .(Паскаль)

Помогите пожалуйста,оченьььь срочно надо!Буду благодарна за решение ,спасибо!!!!!!!

СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО, УМОЛЯЮ, Я УЖЕ 30 РАЗ ЭТО ЗАДАНИЕ ПОСЫЛАЮ, НАПИШИТЕ!!!

1.Дано массив 5*5, заполнить массив случайными числами не больше 30 и найти сумму парных элементов массива, которые находятся под главной диагонали и количество не парных элементов которые находятся над главной диагонали.

Очень вас прошу помочь написать программу.Написать программу-

1)с помощью генератора случайных чисел создать Н числа в диапазоне с [-50;50](длину массива Н надо ввести с клавиатуры)
2)надо вывести сделанный массив на экран
3)нужно вычислить и вывести,какое количество парных чисел
4)и вывести на экран все парные числа.
Очень вас прошу помогите,очень нужно до завтра сделать.Если можете помочь мне,пожалуйста помогите.

СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО,

УМОЛЯЮ, ТОЛЬКО ПРАВИЛЬНО!!!Я УЖЕ 30 РАЗ ЭТО ЗАДАНИЕ ПОСЫЛАЮ, НАПИШИТЕ!!! КТО СМОЖЕТ, ТОЛЬКО ПРАВИЛЬНО! КТО, ЧТО СМОЖЕТ, НО НАДО ВСЕ, НА ЗАВТРА!!!



Вы находитесь на странице вопроса "прошу!!!!!срочно надо!!!ну приииииз!!!! это надо сделать в паскале! пожалуйста!кто нибудь!!!SOS!!!!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.