Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Найти среднее арифметическое элементов массива кратных 5.

5-9 класс

Паскаль.

931722 28 июля 2014 г., 13:51:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bejsennov
28 июля 2014 г., 14:26:10 (9 лет назад)

//Создаем массив, наполняем...
...

Summa:=0;
counterTwo := 0;
for counter := 1 To N Do
       if (Massive[counter] mod 5 = 0) then 
                                                          begin
                                                          Summa:= Summa + Massive[counter];
                                                          counterTwo := counterTwo + 1;
                                                          end;
Writeln(Summa/counterTwo);
readln()
end.
      

Ответить

Другие вопросы из категории

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.

Дан целочисленный массив из 7 элементов: 1) подсчитать произведение элементов массива кратных 5 и кратных 3. 2)подсчитать среднее значение четных

элементов массива. 3) найти минимальное значение среди элементов массива <25 и положительных и номера,соответствующего элемента.

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

1) Составьте программу вычисления в массиве A(N) суммы всех чисел, кратных 3. 2) Составьте программу вычисления в массиве B(8) суммы отрицательных

элементов. 3) Составьте программу вычисления среднего арифметического элементов массива. Пожалуйста.. очень надо!



Вы находитесь на странице вопроса "Найти среднее арифметическое элементов массива кратных 5.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.