Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Срочно!

5-9 класс

составить программу в паскале для вычисления суммы и произведения чисел от 1 до 2.000 делящихся на 10. Сразу проверяйте,чтоб программа была рабочая.

Alina89083141786 23 авг. 2014 г., 6:27:11 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kotova20151
23 авг. 2014 г., 8:42:41 (9 лет назад)

var sum,pr,i:integer; m:array [1..2000] of integer;
begin
 randomize;
 for i:=1 to 2000 do m[i]:=random(2000);
 sum:=0; pr:=1;
  for i:=1 to 2000 do begin
   if m[i] div10=0 then
    sum:=sum+m[i];
     pr:=pr+m[i];
         end;
write(sum);
write(pr);
Проверить,к сожалению,не могк. поздно уже) Но думаю работать будет

Ответить

Другие вопросы из категории

Пожааалуйста помогите!!!!СРОЧНО НУЖНО

подробно
Переведи десятичное число 2325 в двоичную систему счисления.

Помогите Пожалуйста!!!!

1. В 8 корзинах лежит 16 шаров в каждой.Какой объем информации несет сообщение о том,что достали один шар из пятой корзины

2. Загадано число из промежутка от 1 до 64. Какое количество информации необходимо для угадывания числа из этого промежутка?

3.Сообщение
занимает 4 страницы. На каждой странице по 15 строк. В каждой строке по
72 символов. Найдите информационный объем такого текста,если при его
составлении использовали 64- символьный алфавит

Решите пожалуйста:D

Информатика,7 класс по Босовой

Два игрока играют в следующую игру. перед ними лежат три кучки камней, в первый 2 камня, во второй - 3, в третьей - 4. у каждого игрока неограниченное

кол-во камней. игроки ходят по очереди. ход состоит в том, что игрок или удваивает число камней в какой-либо куче, или добавляет по два камня в каждую из куч. выигрывает тот игрок, после хода которого либо в одной из куч становится не менее 15 камней, либо общее число камней во всех трёх кучах становится не менее 25. кто выигрывает при безошибочной игре обоих игроков?

а) игрок, делающий первых ход

б) игрок, делающий второй ход

в) каждый игрок имеет одинаковый шанс на победу

г) для этой игры нет выигрышной стратегии

Читайте также

Срочно нужна сказка об информатике и

человеке! Буду благодарна! 6 класс Уже 4 раз пишу:с На завтра срочно нужно,не знаю что писать :ссс

Срочно! Напишите сообщение про Системный блок. Рзамером, примерно с альбомный лист.

Только содердательно и понятным языком. Срочно, пожалуйста помогите!

:)

ОЧЕНЬ СРОЧНО!!!!!!!

По каналу один за другим идут пароходы "Обь" и "Восток". Навстречу им идут один за другим пароходы "Мир" и "Енисей". Канал такой ширины, что два парохода в нем разойтись не могут. Но с одной стороны канал имеет расширение, в котором может поместиться один пароход. Как можно пароходам разойтись и продолжить свой путь?
Изобразите решение в виде схемы.ЗАРАНЕЕ СПАСИБО!(объясните,кто как может,очень срочно)

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

пожалуйста срочно помогите, очень прошу

тема у нас Организация ветвлений в Паскале. и так, вопрос:
дано трёхзначное число. если сумма цифр числа кратно 3, тогда перевернуть число, иначе обнулить среднюю цифру
очень срочно, кто может



Вы находитесь на странице вопроса "Срочно!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.