Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

задача в паскале. вычислить y^x, где x должно быть натуральное число

10-11 класс

Saleona 20 июня 2013 г., 22:26:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Irinaanton89
20 июня 2013 г., 23:39:20 (10 лет назад)

var

  res, i, y, x : longint;

begin

  read (y, x);

  res := 1;

  for i := 1 to x do

    res := res * y;

  writeln (res);

end.

Ответить

Другие вопросы из категории

объем информационного сообщения 12288 битов можно выразить как:

1Кбайт
0,5мегабайта
1,5килобайта
1,5мегабайта

помогите кто может

срочно надо

Дана вещественная квадратная матрица А порядка n. Найти среднее

арифметическое среди положительных элементов матрицы, находящихся на
главной и побочной диагоналях. Выдать сообщение, если таких элементов нет.

Читайте также

Решить задачу в Паскале:

Задать случайным образом 8
элементов числового массива – числа от 100 до 200. Вставить в него:

а) число «-20» перед 5-ым
элементом.

б) число «0» перед максимальным элементом. В одной задаче должно быть и а и б (но можно и по отдельности, главное, чтобы было верно)))

решите задачки пожалуйста ( задачки должны быть на цикл while) 1. Вклад в банке составляет x рублей. Ежегодно он увеличивается

на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.

Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число.

2. Дано натуральное число

Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в К- ю степень( где К- количество цифр в числе) равна самому числу.

Например, 153=1³ + 5³ + 3³.
Входная строка содержит два натуральных числа- значения а и б.
Входные данные
Входная строка содержит два натуральных числа - значения а и б, разделенных пробелами. Гарантируется, что а≥б.
Выходные данные
Программа должна вывести в одну строчку все числа Армстронга на отрезке а, б, разделив их пробелами. если таких чисел нет, программа должна вывести -1.



Вы находитесь на странице вопроса "задача в паскале. вычислить y^x, где x должно быть натуральное число", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.