Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Заданий двовимірний масив A[n][m] цілих чисел. Складіть програму підрахунку кількості елементів, значення яких співпадають з сумою їх індексів.

10-11 класс

Язык-Pascal. Помогите пожалуйста!

Goranolga 29 июля 2014 г., 20:08:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Veramskva
29 июля 2014 г., 21:01:15 (9 лет назад)

const n=10; m=12;
var b:array[1..n,1..m] of integer;
i,j,k:integer;
begin
k:=0;
for i:=1 to n do
for j:=1 to n do b[i,j]:=random(30)-10;
for i:=1 to n do begin
for j:=1 to n do write(b[i,j]:5);
writeln;
end;
for i:=1 to n do
for j:=1 to n do
if b[i,j]=i+j then k:=k+1;
write ('количество искомых элементов ',k);
writeln;
end.

Ответить

Другие вопросы из категории

1) Вопросы по Железу - Процессоры...
составить программу на паскале:) Имеется четыре A,B,C,D произвольных числа.ЭВМ должна ответить на вопрос: Правда ли что первое число самое большое ,а

последнее самое маленькое? Ответ ЭВМ должна вывести в виде текста-"Правда" или "Неправда"

Читайте также

У двовимірному масиві Х[1..5,1..5]цілих

чисел знайти найменший елемент серед елементів побічної
д

Срочно! Скласти програми до трьох задач!

№1. В одновимірному масиві А[1..10] порахувати середнє арифметичне елементів з парними індексами.

№2. В двовимірному масиві В[1..3,1..3] знайти добуток елементів які знаходяться на непарних рядках. Порахуваті середнє арифметичне всіх від'ємних елементів.

№3. В слові "Мадагаскар" поміняти літери місцями.

Одновимірний масив Х(12) елементів дійсних

чисел. Знайти найбільший додатний елемент і найменший від’ємний елементи масиву.



На Паскале решить задачу. Задан целочисленный вектор Х размерностью n, представляющий последовательность целых чисел. Определить число инверсий

в этой последовательности.

рекомендации: инверсией считать пару элементов, в которой большее число находится перед меньшим (хi>xj, если i>j)

Помогите пожалуйста. Нужно решить в паскале.

Дано масив А[1..n]. Скласти програму підрахунку суми всіх елементів, що знаходяться між елементами А[1] і А[n].



Вы находитесь на странице вопроса "Заданий двовимірний масив A[n][m] цілих чисел. Складіть програму підрахунку кількості елементів, значення яких співпадають з сумою їх індексів.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.