Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Очень прошу, помогите! С информатикой вовсе не дружу! Нужно составить программу на паскале. Задачу не очень помню, звучит примерно так: Сумма покупки 1200

5-9 класс

рублей, скидка предоставляется при покупке свыше 1000 рублей, скидка - 10 %, сумма покупки 1080 рублей. Внизу схема, она правильная!

Daymis 10 июня 2015 г., 20:26:32 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ruslana2000salei
10 июня 2015 г., 21:19:48 (8 лет назад)

Попробуй так
Program qq;
Var a: integer;
Begin
Readln(a);
If a>1000 then
A:=a-(a*0.1)
Else
Writeln(a);
End.

+ 0 -
SvWolf
10 июня 2015 г., 23:21:08 (8 лет назад)

var a:real;
begin
  readln(a);
  if a>1000 then a:=a*0.9;
  writeln(a);
end.

Ответить

Другие вопросы из категории

Нужно привести примеры

1) По признакам
2) По отношению.

Срочно нужна помощь!!

1. С клавиатуры вводят слово и символ. Составть программу, которая:
а) проверяет, есть ли в этом слове заданный символ;
б) определяет позицию заданного символа;
в) подсчитывает количество вхождений заданного символа.
2. С клавиатуры вводят строку и слово. Составть программу, которая:
а) определяет позицию заданного слова;
б) удаляет заданное слово;
в) вставляет в строку заданное слово.
3. Составть программу, которая:
а) из строки "Волга, Днепр, Неман, Енисей" удаляет названия рек, не протекающих по территории Беларуси;
б) из строки "Брест, Бобруйск, Витебск, Гомель, Мозырь, Могилев" удаляет названия городов, не являющихся областными центрами.
4. Составть программу, которая:
а) в строке "край озер" добавляет слова "лесов и рек";
б) в строке "я учусь в школе" заменить слова "в школе" на "в 10-ом классе".
5. Составть программу, которая переставляет на первое место:
а) в строке "моя родина Беларусь" слово "Беларусь";

б) в строке "люблю цябе мой родны кут" слова "мой родны кут".

Помогите плиз!!!!!!!!!!!!!!!!!!!

Какая информация хранится в альфа-канале?

Читайте также

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!

Помогите кто чем может!) НУжно составить программу на языке QBasic. Суть задания: 1)Ввести совю фамилию, имя, отчество как одно текстовое

данное.

а)Определит ьдлину текста.

б)Определить количество букв "b" в нем.

в)Вывести самое длинное слово.

2)Дано предложение. Найти, в каком из слов, состоящего из более чем четырех символов, буква "а" встречается чаще.

По большей части интересует задание 1-в и 2. Буду очень благодарен!!!

ПОМОГИТЕ ПОЖАЛУЙСТА!!!

Даны 2 числа.Найти их сумму,если числа равны,и найти их произведение,если числа не равны.Написать блок схему и составить программу на Паскаль.



Вы находитесь на странице вопроса "Очень прошу, помогите! С информатикой вовсе не дружу! Нужно составить программу на паскале. Задачу не очень помню, звучит примерно так: Сумма покупки 1200", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.