Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

помогите пожалуйста, никак разобраться не могу:( 1)составить программу вычисления n=p*k+n , где p,k,n-любые числа 2) вычислить след.выражение y=k/x,где

5-9 класс

x-целое число, k-целое число не равное нулю

костян34521 14 янв. 2015 г., 19:40:31 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Meison98888
14 янв. 2015 г., 21:12:24 (9 лет назад)

 

 Видимо всё-таки 1) x=p*k+n  где p,k,n-любые числа

 

1)

 

 Program prSum;

Uses Crt;

var res,p,k,n:real;

begin

     clrscr; 

    write('Введите p: ');

 

    readln(p);

write('Введите k: ');

    readln(k);

write('Введите n: ');

    readln(n);

rez:=(p*k)+n; 

writeln('Результат: ', rez); 

end. 

 

 

 

 2) Program Delenie;

Uses Crt;

var y:real;

      x,k:integer; 

begin

     clrscr; 

    write('Введите k: ');

    readln(k);

write('Введите x: ');

  readln(x);

if (x=0) then x:=1; {на ноль делить нельзя !} 

 

  if (k=0) then k:=1; {так как к не должен быть равен нулю}  

y:=k/x ; 

writeln('Результат: ', y); 

end. 

 

Ответить

Другие вопросы из категории

На берегу реки стоит крестьянин с лодкой, а рядом с ним - волк, коза, капуста. Крестьянин должен переправиться сам и перевезти волка, козу и капусту на

другой берег. Однако в лодку кроме крестьянина помещается либо только волк, либо только коза, либо только капуста. Оставлять волка с козой либо козу с капустой без присмотра нельзя (понятно почему). Как должен вести себя крестьянин?

Читайте также

мне ооочень срочно нужно!!! пожалуйста помогите!!!!!!!!помогите решить 2 задачи по Ивт в Паскале: 1)составить программу вычисления в массиве A(

N) произведения нечетных элементов 2)Составьте программу вычисления в массиве B(N) максимального среди отрицательных элементов и его номера. заранее огромное спасибо! очень нужно!

1) Составьте программу вычисления в массиве A(N) суммы всех чисел, кратных 3. 2) Составьте программу вычисления в массиве B(8) суммы отрицательных

элементов. 3) Составьте программу вычисления среднего арифметического элементов массива. Пожалуйста.. очень надо!

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.



Вы находитесь на странице вопроса "помогите пожалуйста, никак разобраться не могу:( 1)составить программу вычисления n=p*k+n , где p,k,n-любые числа 2) вычислить след.выражение y=k/x,где", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.