Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

мне ооочень срочно нужно!!! пожалуйста помогите!!!!!!!!помогите решить 2 задачи по Ивт в Паскале: 1)составить программу вычисления в массиве A(

5-9 класс

N) произведения нечетных элементов 2)Составьте программу вычисления в массиве B(N) максимального среди отрицательных элементов и его номера. заранее огромное спасибо! очень нужно!

Petlyda1957 13 июля 2014 г., 18:32:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maksmironov20
13 июля 2014 г., 20:31:08 (9 лет назад)

var a: array [0..10] of integer;
    i, m: integer;
begin
     m := 1;
          for i := 0 to 10 do
     begin
          a[i] := random(50) - 25;
          writeln('[', i, '] => ', a[i]);
     end;

     for i := 0 to 10 do
         if (a[i] mod 2 = 1) then m := m * a[i];
     writeln(m);
end.

2)
var a: array [0..10] of integer;
    i, m: integer;
begin
     for i := 0 to 10 do
     begin
          a[i] := random(50) - 25;
          writeln('[', i, '] => ', a[i]);
     end;
          for i := 0 to 10 do
         if ((a[i] > a[m]) and (a[i] < 0)) then
            m := i;

     writeln('[', m, '] => ', a[m]);
end.

Можно и меньше циклов, это я для наглядности, чтобы всё не смешивалось =)

Ответить

Другие вопросы из категории

Читайте также

СРОЧНО НУЖНО, ПОЖАЛУЙСТА ПОМОГИТЕ. С ПОЯСНЕНИЕМ, ЕСЛИ МОЖНО....

Дано логическое выражение НЕ(а И b), где a И b - логические величины. При выполнение какого из следующих высказываний данное выражение будет ложным?
А) a и b имеют значение ИСТИНА;

В) a и b имеют значение ЛОЖЬ;

С) a имеет значение ИСТИНА, b имеет значение ЛОЖЬ;

D) a имеет значение ЛОЖЬ, b имеет значение ИСТИНА;

Е) ни a, ни b не имеют значение ИСТИНА.

Пожалуйста помогите решить,не могу разобраться(

решить такую задачу:
Файл размером 100 МБ начинает передаваться с файлового сервера на смартфон через школьное WiFi-соединение
со скоростью 8192 кБит в секунду 1,5 минут.
Затем WiFi-роутер отключили, а остаток файла пришлось получать некоторое время посредством платной 3G-связи.
Определите в какую сумму пользователю обойдётся скачивание файла, если стоимость 1 КБайта составляет 10 копеек.



Вы находитесь на странице вопроса "мне ооочень срочно нужно!!! пожалуйста помогите!!!!!!!!помогите решить 2 задачи по Ивт в Паскале: 1)составить программу вычисления в массиве A(", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.