Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Добрые люди,помогите пожалуйста;)

5-9 класс

Заменить цифры от 1 до 10 словами. Например: 1 - "один" и т.д.Помогите составить программу и блок-схему.

Kvv73 06 июня 2014 г., 5:25:58 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Eldar19salahov95
06 июня 2014 г., 6:13:43 (9 лет назад)

var 
k:integer; 
begin
read(k); 
 if k=1 then write('один'); 
 if k=2 then write('два'); 
 if k=3 then write('три'); 
 if k=4 then write('четыре'); 
 if k=5 then write('пять');     
 if k=6 then write('шесть');     
 if k=7 then write('семь');     
 if k=8 then write('восемь'); 
 if k=9 then write('девять');   
 if k=10 then write('десять'); 
end. 

+ 0 -
Yulya2899
06 июня 2014 г., 8:15:14 (9 лет назад)

заменяет в строке
var
  s : string;
  i, lim : integer;
begin
  readln (s);
  i := 1;
  lim := length (s);
  while (i <= lim) do
  begin
    if s[i] in ['1'..'9'] then
    begin
      if (s[i] = '1') and (i <> length (s)) and (s[i+1] ='0') then
      begin
        write ('ten');
        inc (i);
      end
      else
      case s[i] of
        '1' : write ('one');
        '2' : write ('two');
        '3' : write ('three');
        '4' : write ('four');
        '5' : write ('five');
        '6' : write ('six');
        '7' : write ('seven');
        '8' : write ('eight');
        '9' : write ('nine');
      end;
    end
    else write (s[i]);
    inc (i);
  end;
end.

+ 0 -
Тори5
06 июня 2014 г., 10:49:55 (9 лет назад)

pascal? а цифра сама по себе или в тексте?

+ 0 -
Lika2605
06 июня 2014 г., 13:41:07 (9 лет назад)

Да,паскаль.В смычле сама по себе или в тексте???

Ответить

Другие вопросы из категории

Помогите сделать пожалуйста Очень срочно!

Информатика 8 класс.

1) Производится одноканальная (моно)

звукозапись с частотой дискретизации 128 Гц. При записи использовались 64
уровня дискретизации. Запись длится 6 минут 24 секунд, её результаты
записываются в файл, причём каждый сигнал кодируется минимально возможным и
одинаковым количеством битов. Какое из приведённых ниже чисел наиболее близко к
размеру полученного файла, выраженному в килобайтах?

Витя работает недалеко от одной из станций кольцевой линии Московского метро, а живет рядом с другой станцией той же линии. Требуется выяснить, мимо

какого наименьшего количества промежуточных станций необходимо проехать Вите по кольцу, чтобы добраться с работы домой.
Формат входных данных
Станции пронумерованы подряд натуральными числами 1, 2, 3, …, N (1-я станция – соседняя с N-й), N не превосходит 100.
Вводятся три числа: сначала N – общее количество станций кольцевой линии, а затем i и j – номера станции, на которой Витя садится, и станции, на которой он должен выйти. Числа i и j не совпадают. Все числа разделены пробелом.
Формат выходных данных
Требуется выдать минимальное количество промежуточных станций (не считая станции посадки и высадки), которые необходимо проехать Вите.
Примеры
Входные данные

Выходные данные

Комментарий

100 5 6

0

На кольцевой линии 100 станций; проехать с 5-й на 6-ю станцию Витя может напрямую, без промежуточных станций

10 1 9

1

На кольцевой линии 10 станций; проехать с 1-й на 9-ю станцию Витя может через одну промежуточную, ее номер 10

1. Текстовый редактор представляет собой программный продукт, входящий в состав____________

2. Операционные системы представляют собой программные продукты, входящие в состав_____________
3. Программы обслуживания устройств компьютера называются_____________
4. Прикладные программы- это программы для_________________

1. Операционная система — это___________________
2. Программы обслуживания устройств компьютера называются____________________
3. Программой архиватором называют программу, которая_______________
4. В прикладное ПО входят________________________

Читайте также

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)

Всем информатикам сюда. Помогите пожалуйста,люди добрые...(

1)S=1+2+3...+10
for, while, repeat.

2)S=2+4+6+8...+20

for, while, repeat.
надо короче решить с помощью этих трех программ этот пример. что бы выходил этот ответ...помогите пожалуйста.

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!



Вы находитесь на странице вопроса "Добрые люди,помогите пожалуйста;)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.