Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Найдите и выведите на экран все двузначные числа, сумма которых не меняется при умножение на два.

5-9 класс

Нужно написать программку в паскале.

Leppi 15 дек. 2015 г., 3:33:43 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
5558884545
15 дек. 2015 г., 5:02:02 (8 лет назад)

Решение:
■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■
uses CRT;
var
STR1, STR2 : String;
OK : boolean;
i, ii : Integer;

begin

Write('1): ');
ReadLn(STR1);
Wrute('2): ');
ReadLn(STR2);

for i:=1 to Length(STR2) do begin
OK:=false;
for ii:=1 to Length(STR1) do begin
if (STR2[i] = STR1[ii]) then begin OK:=true; break; end;
end;
if (OK = false) then break;
end;

if (OK = false) then begin WriteLn('NO'); end
else begin WriteLn('YES'); end;

end.

Ответить

Другие вопросы из категории

Составьте программу, которая формирует массив из шестнадцати случайных целых чисел от -20 до 20 и:

а) находит элементы с нулевыми значениями;

б) находит индексы четных элементов;

в) подсчитывает кол-во отрицательных элементов;

г) Определяет, есть ли в этом массиве хотя бы одно число, кратное трем;

д) находит в этом массивеиндексы элементов, значения которых кратны трем;

Помогите, пожалуйста

1.

Читайте также

Помогите пожалуйста, срочно надо.

Заранее большое спасибо)
1) Определите и выведите на экран количество четырехзначных чисел, которые делятся без остатка одновременно на 5 и 11.
2) Найдите и выведите на экран все двузначные числа, у которых при умножения на 2 сумма цифр увеличивается на 5.

Нужна помощь в составлении алгоритма (паскаль АВС) -8 класс.

1 задание: Составьте программу вычисления количества двухзначных чисел,которые кратны 2 и 3.
2 задание: Составьте программу,выводящую на экран все двузначные числа,у которых первая цифра в два раза больше второй.
3 задание: Найдите количество двузначных чисел,которые делятся на сумму своих цифр.
P.S. Помогите пожалуйста! Очень нужно и срочно! Если можете,то нужно всё сделать; если же нет,то хотя-бы одну или две задачи. Заранее спасибо!!!)))



Вы находитесь на странице вопроса "Найдите и выведите на экран все двузначные числа, сумма которых не меняется при умножение на два.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.