Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

6.1 с помощью подпрограм (процедура ввода -процедура вывода),ввод значений в ручную а не рандом

10-11 класс

Jvanov1247 18 марта 2017 г., 11:20:22 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maya84
18 марта 2017 г., 13:50:43 (7 лет назад)

type
  M = array[,] of integer;// двумерный динамический массив
  RefElem = record
    row: integer;
    col: integer;
  end;


procedure InputMas(var a: M; MasName: string := '');
// Организует ввод элементов массива
var
  n, m, i, j: integer;
begin
  writeln('Укажите число строк и колонок массива ', MasName);
  readln(n, m);
  SetLength(a, n, m);
  writeln('Вводите элементы массива построчно');
  for i := 0 to n - 1 do
    for j := 0 to m - 1 do
      read(a[i, j]);
end;

procedure SwapElems(var a: M; col: integer; i1: integer; i2: integer);
// Меняет местами в колонке col массива "а" элементы строк i1, i2
var
  buf: integer;
begin
  buf := a[i1, col];
  a[i1, col] := a[i2, col];
  a[i2, col] := buf
end;

procedure ColMinMax(var a: M; col: integer);
// Процедура находит и обменивает местами максимальный и минимальный элементы,
// элемента, найденные в колонке col массива а
// Вызываемые процедуры: SwapElems
var
  i, eMax, eMin, iMax, iMin: integer;

begin
  eMax := -32768;  //меньше не бывает
  eMin := 32767;   //больше не бывает
  for i := 0 to Length(a, 0) - 1 do
  begin
    if eMin > a[i, col] then begin
      eMin := a[i, col];
      iMin := i;
    end;
    if eMax < a[i, col] then begin
      eMax := a[i, col];
      iMax := i;
    end
  end;
  SwapElems(a, col, iMax, iMin)
end;

procedure MinMax(var a: M);
// Обменивает местами в каждой колонке массива а минимальный и мексимальный элементы
// Вызываемые процедуры: ColMinMax
var
  j: integer;
begin
  for j := 0 to Length(a, 1) - 1 do
    ColMinMax(a, j)
end;

procedure WriteMas(a: M; title: string);
// Вывод массива a с заголовком title
var
  i, j: integer;
begin
  writeln('Массив ', title);
  for i := 0 to Length(a, 0) - 1 do
  begin
    for j := 0 to length(a, 1) - 1 do
      write(a[i, j]:5);
    writeln
  end
end;

procedure Action(var a: M; title: string);
// Делает все необходимые операции с массивом
begin
  InputMas(a, title);
  WriteMas(a, '*** Исходный массив ***');
  MinMax(a);
  WriteMas(a, '*** Результирующий массив ***')
end;

var
  A1, A2, A3: M;

begin
  Action(A1, 'A1');
  Action(A2, 'A2');
  Action(A3, 'A3')
end.

Тестовый прогон:

Укажите число строк и колонок массива A1
3 3
Вводите элементы массива построчно
3 5 7 0 2 5 4 3 4
Массив *** Исходный массив ***
    3    5    7
    0    2    5
    4    3    4
Массив *** Результирующий массив ***
    3    2    4
    4    5    5
    0    3    7
Укажите число строк и колонок массива A2
3 5
Вводите элементы массива построчно
1 2 3 4 5
5 4 3 2 1
3 3 3 3 3
Массив *** Исходный массив ***
    1    2    3    4    5
    5    4    3    2    1
    3    3    3    3    3
Массив *** Результирующий массив ***
    5    4    3    2    1
    1    2    3    4    5
    3    3    3    3    3
Укажите число строк и колонок массива A3
5 3
Вводите элементы массива построчно
1 2 3 4 5 6 7 8 9 8 4 2 9 0 2
Массив *** Исходный массив ***
    1    2    3
    4    5    6
    7    8    9
    8    4    2
    9    0    2
Массив *** Результирующий массив ***
    9    2    3
    4    5    6
    7    0    2
    8    4    9
    1    8    2



Ответить

Другие вопросы из категории

Подсчитайте, сколько байт в памяти занимает рисунок размером 20 на 80 пикселов, закодированный с палитрой 128 цветов. Место для хранения палитры не

учитывайте.
Как называется характеристика монитора, которая определяет, как именно отображается на нём цвет с заданным RGB-кодом?

(По нескольким определениям отгадайте термин информатики

Текстовое, числовое, денежное, ключевое, логическое ̶ …
Ответ записать в именительном падеже единственном числе.

Как записать пример в excel

1. y=cos^2(x)sin(5x)

Читайте также

1. написать программу, производящее "неформатный" вывод разных значений

2. написать программу, производящее "форматный" вывод разных значений
3. написать программу использующие процедуру writeln c параметрами и без параметров

составить графическую схему алгоритма и написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная

матрица NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты. Подсчитать общее количество чисел, меньших заданного А, и чисел, больших заданного В среди элементов, находящихся ниже побочной диагонали.

Задача на ввод-вывод и арифметические операции.

Данные вводятся с клавиатуры или из файла input.txt, выводятся на экран или в файл output.txt.

написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная матрица

NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты.

Найти в каждом четном по номеру столбце матрицы максимальный элемент и вычислить произведение этих элементов.

тест 7 леких вопросов с выбором ответа

13. Тактовая частота процессора – это:

A. число двоичных операций, совершаемых процессором в единицу времени

B. число вырабатываемых за одну секунду импульсов, синхронизирующих работу узлов компьютера

C. число возможных обращений процессора к оперативной памяти в единицу времени

D. скорость обмена информацией между процессором и устройствами ввода/вывода

14.Укажите минимально необходимый набор устройств, предназначенных для работы компьютера:

A. принтер, системный блок, клавиатура

B. процессор, ОЗУ, монитор, клавиатура

C. процессор , стриммер, винчестер

D. монитор, системный блок, клавиатура

15. Что такое микропроцессор?

A. интегральная микросхема, которая выполняет поступающие на ее вход команды и управляет

работой компьютера

B. устройство для хранения тех данных, которые часто используются в работе

C. устройство для вывода текстовой или графической информации

D. устройство для вывода алфавитно-цифровых данных

16.Взаимодействие пользователя с программной средой осуществляется с помощью:

A. операционной системы

B. файловой системы

C. приложения

D. файлового менеджера

17.Непосредственное управление программными средствами пользователь может осуществлять с

помощью:

A. операционной системы

B. графического интерфейса

C. пользовательского интерфейса

D. файлового менеджера

18. Способы хранения данных на физическом носителе определяет:

A. операционная система

B. прикладное программное обеспечение

C. файловая система

D. файловый менеджер

19. Графическая среда, на которой отображаются объекты и элементы управления системы Windows,

созданная для удобства пользователя:

A. аппаратный интерфейс

B. пользовательский интерфейс

C. рабочий стол

D. программный интерфейс

20. Скорость работы компьютера зависит от:

A. тактовой частоты процессора

B. наличия или отсутствия подключенного принтера

C. организации интерфейса операционной системы

D. объема внешнего запоминающего устройства



Вы находитесь на странице вопроса "6.1 с помощью подпрограм (процедура ввода -процедура вывода),ввод значений в ручную а не рандом", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.