Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задача на ввод-вывод и арифметические операции.

10-11 класс

Данные вводятся с клавиатуры или из файла input.txt, выводятся на экран или в файл output.txt.

15ni03 27 авг. 2013 г., 18:20:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kfdbkfc744
27 авг. 2013 г., 18:53:23 (10 лет назад)

Pascal:
var a,b:real;
begin
  readln (a,b);
  writeln (sqrt(a*a+b*b));
end.

C++:
#include <iostream>
#include <cmath>
using namespace std;

int main()
{
  float a,b;
  cin >>a >>b;
  cout <<sqrt(a*a+b*b);
  return 0;
}

+ 0 -
Elita0606
27 авг. 2013 г., 20:56:39 (10 лет назад)

#include <iostream>
#include <conio.h>
#include <math.h> 
using namespace std;

main ()
{   
 int a,b;   
cin>>a>>b;    //вводим а и б
cout<<endl<<sqrt(a*a+b*b);    //выводим число по формуле
getch();   
return 0;
}

Ответить

Другие вопросы из категории

Циклические алгоритмы и разработка программы

Циклы с параметрами
Разработать схему алгоритма (блок схему), написать программный код на языке паскаль, используя оператор FOR.

Читайте также

Олимпиадные задачи требуют ввод-вывод данных с использованием внешних файлов как это сделать? ИНФОРМАТИКА конспекты уроков 9-11 классы Чернов

А.А. с198

program pr;

uses crt;

var f:file of integer;

n:integer;

a:string;

begin

clrscr;

a:='c:\f1.txt';

assign(f,a);

rewrite(f);

writeln('n: ');

readln(n);

write(f,n);

close (f);

readln;

end.

после выполнения программы в файле f1.txt вместо значения n=5 появилось -256

что не так ?

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Решить любую из двух задач. Если две - то спасибо :)

1) В одномерном массиве встречаются нули. Согнать их всех в одну сторону.(задача на пузырьковый метод)
2) После ввода одномерного массива:
-сначало идут положительные по возрастанию

-потом все нули

-потом все отрицательные чила по возрастанию

Пример:-1 5 -7 0 3 0 -2 6 8

вывод: 3 5 6 8 0 0 -7 -2 -1

Помогите, очень прошу вас.

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.



Вы находитесь на странице вопроса "Задача на ввод-вывод и арифметические операции.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.