Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

While17. Дано целое число N (> 0). Используя операции деления нацело ивзятия остатка от деления, вывести все его цифры, начиная с самой

5-9 класс

правой(разряда единиц). (Pascal ABC)

НяШеЧкА1 24 янв. 2016 г., 21:09:36 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zara4
24 янв. 2016 г., 22:49:01 (8 лет назад)

var
  n, x, a: integer;
begin
write('Введите число: ' );
readln(n);  
while (n > 0 ) do
   begin
   a := n mod 10;
   x := x * 10 + a;
   n := n div 10;
   end; 
writeln('Ответ: ', x); 
end.

Ответить

Другие вопросы из категории

Помогите) пожалуйста ребят.
Решите пожалуйста)) Паскаль:

в одномерном массиве произвольных чисел требуется заменить числом 100 значения всех элементов, удовлетворяющих условию A[i]>=5

Постройте схемы состава для следующих объектов:

А) Аппаратное обеспечение компьютера
Б) Дерево

Читайте также

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

плз помогите.. составить программу на языке авс паскаль 1)напишите программу, которая считывает два целых числа a и b

и выводит наибольше значение из них. Числа - целые от 1 до 1000.

при решении задачи можно пользоваться только целочисленными арифметическими операциями +,-,*,//,%,=. нельзя пользоваться нелинейными конструкциями:ветвления, циклами, функциями вычисления модуля, извлечения квадратного корня., и условными функциями!!!!!!!

2) Дано целое число N. Выведите следующее за ним четное число. При решении задачи нельзя использовать условную инструкцию if и циклы!!

хотя бы формулу:) заранее спасибо)

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).



Вы находитесь на странице вопроса "While17. Дано целое число N (> 0). Используя операции деления нацело ивзятия остатка от деления, вывести все его цифры, начиная с самой", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.