Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

удалить из предложения произвед символов и след.за ним 3 символа

5-9 класс

KIRA172003 26 авг. 2013 г., 12:36:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Docdiman
26 авг. 2013 г., 13:26:38 (10 лет назад)

удалить произведение символов - это некорректное задание

допустим, надо удалить символ произведения и следующие за ним 3 символа,

при этом предполагаем, что символ произведения в строке есть и после него присутствует как минимум еще 3 символа

var
s,r:string;
i,k:integer;
begin
readln(s);
i:=1;
while (s[i]<>'*') and (i<=length(s)) do
i:=i+1;
r:='';
for k:=1 to i-1 do r:=r+s[k];
for k:=i+4 to length(s) do
r:=r+s[k];
writeln(r);
end.

Ответить

Другие вопросы из категории

Выполнить в Паскале:

Массив из 5 вещественных чисел вводится с клавиатуры. Найти среднее арифметическое, min и max элементов массива.

Читайте также

плз помогите.. составить программу на языке авс паскаль 1)напишите программу, которая считывает два целых числа a и b

и выводит наибольше значение из них. Числа - целые от 1 до 1000.

при решении задачи можно пользоваться только целочисленными арифметическими операциями +,-,*,//,%,=. нельзя пользоваться нелинейными конструкциями:ветвления, циклами, функциями вычисления модуля, извлечения квадратного корня., и условными функциями!!!!!!!

2) Дано целое число N. Выведите следующее за ним четное число. При решении задачи нельзя использовать условную инструкцию if и циклы!!

хотя бы формулу:) заранее спасибо)

На перекрестке произошло дорожно-транспортное путешествие, в котором участвовали автобус(А), грузовик(Г), легковой автомобиль(Л) и маршрутное такси(М).

Свидетели происшествия дали показания инспектору ГИБДД. Первый свидетель считал, что первым на перекресток выехал автобус, а маршрутное такси было вторым. Другой свидетель полагал, что последним на перекресток выехал легковой автомобиль, а вторым был грузовик. Третий свидетель уверял, что автобус выехал на перекресток вторым,а следом за ним - легковой автомобиль. В результате оказалось, что каждый из свидетелей был прав только в одном из своих утверждений. В каком порядке выехали машины на перекресток? В ответе перечислите подряд без пробелов первые буквы названий транспортных средств в порядке их выезда на перекресток, например АМЛГ. ( Пожалуйста, будьте добры с решением ;)

Написать

программу, которая по номеру месяца выдает название следующего за ним месяца
(при т = 1 получаем февраль, 4 — май).

И так друзья, я решаю чемпионат по информатике.. Вот 1 задание, пожалуйста, помогите решить, заранее очень благодарен:)

Вопрос:
В слове ЧЕМПИОНАТ поменяли местами буквы, стоящие на нечетных и следующих за ними четных позициях.Группы идущих подряд согласных букв какой длины можно найти в том, что случилось?
Варианты ответа:
А) 1
Б) 2
В) 3



Вы находитесь на странице вопроса "удалить из предложения произвед символов и след.за ним 3 символа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.