Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Выполнить в Паскале:

5-9 класс

Массив из 5 вещественных чисел вводится с клавиатуры. Найти среднее арифметическое, min и max элементов массива.

Greenkit111 19 авг. 2013 г., 21:47:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
124561
20 авг. 2013 г., 0:30:17 (10 лет назад)

var i,n:Integer;
A:Array[1..1000] of Real;
sum,srednee,max,min:Real;
Begin
 Read(n);
 for i:=1 to n do
  Read(A[i]);
 for i:=1 to n do
  sum:=sum+A[i];
  srednee:=sum/n;
 max:=A[1];
 min:=A[1];
 for i:=1 to n do
  begin
   if (A[i]>max) then max:=A[i];
   if (A[i]<min) then min:=A[i];
  end;
 Writeln('Srednee = ',srednee:0:2,' Min = ',min:0:2,' Max = ',max:0:2);
end.

Ответить

Другие вопросы из категории

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

Читайте также

Программа выполняется в Паскале! Дано целое число N (> 0). С помощью операций деления нацело и взятия остатка от деления определить, им

еются ли в записи числа N нечетные цифры. Если имеются, то вывести True, если нет — вывести False. Помогите плииз.

1. Сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен случайному трехзначному числу;
2-й равен текущему индексу, увеличенному в 10 раз;
3-й равен сумме двух предыдущих элементов.

(программу надо выполнить в Паскале)

Программа выполняется в Паскале! Составьте программу для решения следующей задачи:Дядюшка подарил своему племяннику на первый день

рождения 1 доллар. В каждый следующий день рождения он удваивал свой подарок и прибавлял к нему столько долларов, сколько лет исполнилось его племяннику. Определите, к какому дню рождения сумма превысит 100 долларов? Помогите плииз.



Вы находитесь на странице вопроса "Выполнить в Паскале:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.