Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дан массив ll, содержащий 12 элементов вещественного типа - положительных, отрицательных и равных нулю. Сосчитать количество не нулевых элементов массива

10-11 класс

и сформировать из них новый массив. Найти модуль суммы элементов нового массива. Пожалуйста помогите.

п4469854 31 окт. 2016 г., 22:21:48 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ИrinА
01 нояб. 2016 г., 1:09:23 (7 лет назад)

program gt;
var a,b:array[1..1000]of real;
i,n,k:longint;
s:real;
begin
read(n);
k:=0;
for i:=1 to n do
begin
read(a[i]);
if(a[i]<>0)then begin
k:=k+1;
s:=s+a[i];
b[k]:=a[i];
end;
end;
s:=abs(s);
writeln(s);
end.

Ответить

Другие вопросы из категории

Var k,s Integer

begin
s:=0
k:=0
while s<66 do begin
k:=k+3
s:=s+k
end
write(k)
end

Умоляю, помогите!!

очень надо))спасибо)

Помогите пожалуйста!! Какое из слов лишнее и кратко объяснить почему?

начиная с 23задания и до конца

Читайте также

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

Помогите пожалуйста, очень срочно!

Дан массив А , содержащий N элементов .Найти произведение отрицательных элементов массива и их количество. Нарисовать блок-схему. Просчитать значения: N=10 , массив А={-2;0;10;-1;7;3;0}

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:



Вы находитесь на странице вопроса "дан массив ll, содержащий 12 элементов вещественного типа - положительных, отрицательных и равных нулю. Сосчитать количество не нулевых элементов массива", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.