Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

,,ввести с клавиатуры последовательность из n. целых чисел и найти максимальное число среди элементов . Стоящих на четных местах

10-11 класс

Kasyanova98 08 дек. 2014 г., 21:19:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pro100valentina
08 дек. 2014 г., 23:03:35 (9 лет назад)

Program ArrayMax;
Const n = 10;
Var a: Array [1..n] of Integer;
i, b: Integer;
Begin
WriteLn('Введите ', n, ' целых чисел через пробел и нажмите Enter');
For i := 1 To n Do
Read(a[i]);
b := a[2];
For i := 1 To n Do
If (i Mod 2 = 0) And (a[i] > b) Then
b := a[i];
Write('Результат: ', b);
End.

Ответить

Другие вопросы из категории

. В формировании цепочки из четырех бусин используются некоторые правила: В конце цепочки стоит одна из бусин Р, N, Т, O. На первом – одна из бусин P,

R, T, O, которой нет на третьем месте. На третьем месте – одна из бусин O, P, T, не стоящая в цепочке последней. Какие из перечисленных цепочек созданы с учетом этих правил? 1) PORT 2) TTTO 3)TTOO 4) OOPO 5) РТON 6) ONNO

Составить блок-схему и написать программу Паскаль.

"Мужик и чёрт".
помогите, пожааалуйста!

Читайте также

Помогите срочно нужно программирование в паскале !! написать программу!!

1 ввести с клавиатуры последовательность из N чисел и найти максимальное число среди элементов стоящих на чётных местах.
2 Выяснить является ли натуральное число K степенью 3.

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

Помогите, пожалуйста, очень, очень надо. Написать программу с помощью цикла, которая позволяет ввести с клавиатуры последовательность из трех

дробных чисел и после ввода каждого числа выводит среднее арифметическое полученной части последовательности. Ниже представлен рекомендуемый вид экрана во время работы программы:

*Обработка последовательности дробных чисел*

После ввода каждого числа нажмите <Enter>

- > 12.3

Введено чисел: 1 Среднее арифметическое: 12.30

- > 15

Введено чисел: 2 Среднее арифметическое: 13.65

- > 10

Введено чисел: 3 Среднее арифметическое: 12.43

ЗАДАЧА В ПАСКАЛЕ дана непустая последовательность целых чисел оканчивающаяся нулем.найти: а) наибольшее число б) разность

максимального и минимального

в) максимальный элемент из стоящих на четных местах

г) сумму положительных и среднее арифметическое отрицательных

д) второй максимум

е) длину наибольшего фрагмента, состоящего из одинаковых элементов.

ЗАРАНЕЕ ОГРОМНОЕ СПАСИБО ЗА РЕШЕНИЕ ХОТЯ БЫ ОДНОЙ ИЗ ЗАДАЧЕК...))))))

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.



Вы находитесь на странице вопроса ",,ввести с клавиатуры последовательность из n. целых чисел и найти максимальное число среди элементов . Стоящих на четных местах", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.