Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны площадь S1 круга и площадь S2 квадрата определите поместиться ли круг в квадрат. Напишите программу на паскале

5-9 класс

Герберт 08 февр. 2015 г., 7:03:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Katnaumjva123
08 февр. 2015 г., 9:52:50 (9 лет назад)

var s1,s2,r,a:real;
begin
read(s1,s2);
r:=sqrt(s1/pi);
a:=sqrt(s2);
if a*sqrt(2)/2<=r then writeln('Поместится')
else writeln('Не поместится');
end.

Вроде так, но проверьте на своих тестах

Ответить

Другие вопросы из категории

нужна помощь, ребята!

определить значение переменной S после выполнения следующего фрагмента алгоритма, представленного в виде блок-схемы, если а=692.
Начало:
1) ввод а,
2) S:=0
3) S:=s+a mod 10
4) a:=a div 10
5) a=0, если нет, то вернуться к 3 действию если да то вывод S
6) конец

Помогите срочно!

Выразите обьем информации в различных единицах,заполняя таблицу.

Помогите срочнооооооо

Читайте также

помогите пожалуйста с информатикой вот такие задачки:

Линейные программы.
Напишите программу на ШАЯ. Вычислите площадь боковой поверхности куба. S=4a(в квадрате)
Условный оператор (ветвление)
Нарисуйте блох-схему. Найдите решение уравнения ax+b=0 если оно отсутствует.
Циклы
Напишите программу на Паскале. Вводится последовательность из N целых чисел. Сколько отрицательных чисел и сумма положительных чисел?
Одномерные массивы
Напишите программу на паскале. В одномерном массиве вычислите сумму положительных элементов.
Двумерные массивы
Напишите программу на паскале. Дан квадратный целочисленный массив. Уменьшить в два раза все его элементы.

Если что извините, надеюсь не много прошу.



Вы находитесь на странице вопроса "Даны площадь S1 круга и площадь S2 квадрата определите поместиться ли круг в квадрат. Напишите программу на паскале", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.