Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

С клавиатуры вводятся 3 числа, подсчитать сколько среди них четных положительных чисел.

5-9 класс

PS: использовать функцию деления по модулю:
a mod b- выдает остаток при делении числа а на число b
15 mod 2=1
15 mod 3=0

Danielparpauts 23 янв. 2014 г., 12:23:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Asb348
23 янв. 2014 г., 13:03:47 (10 лет назад)

var   a,b,c,k:integer;
begin   
   k:=0;   
   writeln('Input a,b,c');
   read(a,b,c);   
   if (a > 0) and (a mod 2 = 0) then inc(k);   
   if (b > 0) and (b mod 2 = 0) then inc(k);   
   if (c > 0) and (c mod 2 = 0) then inc(k);   
   writeln;   
   write('K = ',K);
end.

Ответить

Читайте также

1.С клавиатуры вводится действительное число a.Найти его квадратный корень.

2.С клавиатуры вводится действительное число p.Записать отдельно его целую часть C.
Помогите составить программу.

Помогите решить срочно пожалуйста

Задача в pascal Цикл с условием
Первая задача:
S=1+2+3+4+.....+
вторая задача:
С клавиатуры вводятся целые числа 0 на конце,средние значение положительных чисел.

В ПАСКАЛЕ!№1 С клавиатуры вводятся 10 натуральных двузначных чисел. Определить сколько среди них чисел, кратных 4; №2 С клавиатуры вводятся 10

натуральных двузначных чисел. Определить

среднее арифметическое нечетных чисел;

№3 С клавиатуры вводятся 10 натуральных двузначных чисел. Определить

верно ли, что среди введенных чисел есть число, в котором первая цифра в два раза больше последней.

Помогите очень срочно! 315. По данному натуральному n вычислите сумму 1^2 + 2^2+...+n^2. Вводится единственное число n. Необходимо вывести вычисленную

сумму. 346.Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел. 347.Вводится число N, а затем N чисел. Выведите YES, если среди введенных чисел есть хотя бы один нуль, или NO в противном случае.



Вы находитесь на странице вопроса "С клавиатуры вводятся 3 числа, подсчитать сколько среди них четных положительных чисел.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.