Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите написать программу 2,3,4,5. или любые 3 из них. на паскале.

5-9 класс

Cirilav90 21 июля 2013 г., 10:32:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kijvhkugcgcu
21 июля 2013 г., 11:33:56 (10 лет назад)

2 задание сделал через рекурсию.
function nod (a, b : integer) : integer;
begin
if (a = 0) or (b=0)
then result := a;
else
result := (b, a mod b);
end.

var
a, b : integer;
begin
read(a, b);
write(nod(a, b));
end.

5 задание
function nod (a, b : integer) : integer;
begin
if (a = 0) or (b=0)
then result := a;
else
result := (b, a mod b);
end.

var
a, b : integer;
begin
read(a, b, c);
write(nod(a, b),c);
end.

Ответить

Другие вопросы из категории

Задача 1 балл

[Компьютерные расширения]

Папа Дяди Федора очень любит кино. Помоги ему выбрать форматы файлов, которые являются контейнерами для хранения видеофильмов.


3GP
AIF
MKV
M4A
AVI
TIFF
WAV

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

Помогите решить арифметическую операцию в позиционных системах счисления

Очень надо
нужно проверку помочь сделать

Продавец продаёт шапку. Стоит 10 р. Подходит покупатель, меряет и согласен взять,но у него есть только банкнота 25 р.Продавец отсылает мальчика с этими 25

р. к соседке разменять.Мальчик прибегает и отдаёт 10+10+5.Продавец отдаёт шапку и сдачу 15 руб.Через какое-то время приходит соседка и говорит, что 25 р. фальшивые, требует отдать ей деньги.Ну что делать.Продавец лезет в кассу и возвращает ей деньги.

Читайте также

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни



Вы находитесь на странице вопроса "помогите написать программу 2,3,4,5. или любые 3 из них. на паскале.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.