Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите переделать программу в процедуру без параметров

5-9 класс

program Pl_kruga;
uses crt;
var L,S,R:real;

BEGIN
writeln(введи...);
readln(L);
R:=L/2*3.14;
S:=3.14*R*R;
writeln(S:4:2);
end.

Дианочка328 16 февр. 2017 г., 5:09:47 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dinaziada
16 февр. 2017 г., 7:38:58 (7 лет назад)

program Pl_kruga;

uses
  crt;

procedure SKr(L: real; var S: real);
var
  R: real;
begin
  R := L / 2 * Pi;
  S := Pi * sqr(R);
end;

{ а это вызов }

var
  L, S: real;

begin
  Writeln('введи...');
  Readln(L);
  SKr(L, S);
  Writeln(S:4:2)
end.

Ответить

Другие вопросы из категории

Помогите, пожалуйста. Заранее спасибо. 1. Массив это:

a) совокупность данных одного типа с общим для всех элементов именем.
b) именованная область внешней памяти, содержащая какую либо информацию
c) информация на внешнем носителе

2. Что такое индекс массива?
a) Размерность массива;
b) Глубина массива;
c) Ширина массива;
d) Объем массива.

3. Числовой одномерный массив B заполнен последовательно цифрами 2, 5, 7, 34. Каково будет значение элемента B (3)?
a) 34; b) 5; c) 7; d) 2.

4. Какие значения примут элементы массива A[3] и A[4] после выполнения последовательности операторов, если первоначально
A[3] := 2;
A[4] := 3;
B := A[3];
A[3] := A[4];
A[4] := B?
1) A[3] = 3; A[4 = 3
2) A[3] = 3; A[4] = 0
3) A[3] = 3; A[4] = 2
4) A[3] = 2; A[4] = 3

5. В представленном фрагменте программы значения одномерного массива задаются с помощью оператора цикла. Чему будет равно A[5]?
For i := 1 To 5 Do
Begin
A[2*i - 1] := i;
A[2*i] := i*i
End;

6. Сколько элементов содержится в массиве var c: array [2..23] of integer;
A) 23;
B) 21;
C) 22;
D) 2;
7. В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:
for i:=0 to 10 do
A[i]:= i + 1;
for i:=0 to 10 do
A[i]:= A[10-i];
Чему будут равны элементы этого массива?
​1) 10 9 8 7 6 5 4 3 2 1 0
​2) 11 10 9 8 7 6 5 4 3 2 1
​3) 11 10 9 8 7 6 7 8 9 10 11
​4) 10 9 8 7 6 5 6 7 8 9 10

Сколько всего зеркальных пятизначных чисел?

(с решениями)

Читайте также

Кто добрый человек - помогите Даю 15 баллов

Чем отличаются процедуры без параметров от процедур с параметрами?

Помогите с программой по информатике

Найти средний рост класса. Написать программу. 10 человек
Самый наименьший рост 162 самый высокий 170

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






Добрые люди,помогите пожалуйста;)

Заменить цифры от 1 до 10 словами. Например: 1 - "один" и т.д.Помогите составить программу и блок-схему.



Вы находитесь на странице вопроса "помогите переделать программу в процедуру без параметров", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.