Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1. Составить программу для нахождения произведения чисел от 1 до 15

10-11 класс

2. Дан массив целых чисел. Найти Max элемент

LisaB 17 июля 2013 г., 4:37:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anyalime
17 июля 2013 г., 6:53:03 (10 лет назад)

1./////////////////////////////////

#include<iostream>
using namespace std;
int fact(int a)
{
  if(a==1) return 1;

+ 0 -
Bratashina
17 июля 2013 г., 7:48:49 (10 лет назад)

program Prod15;

var
  p: int64;
  i: integer;

begin
  p := 1;
  for i := 2 to 15 do p := p * i;
  writeln('Произведение целых от 1 до 15 равно ', p)
end.

Тестовое решение:
Произведение целых от 1 до 15 равно 1307674368000

program emax;

const
  n = 20;

var
  i, amax: integer;
  a: array[1..n] of integer;

begin
  amax := -32768;
  writeln('Введите 20 целых чисел');
  for i := 1 to 20 do
  begin
    read(a[i]);
    if amax < a[i] then amax := a[i]
  end;
  writeln('Максимальное из чисел равно ', amax)
end.

Тестовое решение:
Введите 20 целых чисел
-5 12 0 34 26 -77 11 0 34 -23 7 0 -14 -8 34 -15 27 0 -45 23
Максимальное из чисел равно 34





Ответить

Другие вопросы из категории

Читайте также

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Составить программу для нахождения наименьшего общего кратного четырех натуральных чисел:по формуле НОК(A,B)=(A*B)/НОД(A*B)

(Определить процедуру, распознающую НОД двух чисел)

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99

Помогите пожалуйста решить задачи в турбо Паскале!

1) Определить количество двухзначных чисел, сумма цифр которых равна числу N.
2) Составить таблицу для двух столбцов выражения y=x²+3. Ввод чисел через клавиатуру.
3) Составить программу вычисления суммы кубов чисел от 1 до 5.
4) Вычислить сумму части ряда, 1/3, 1/6, 1/9, 1/12....
5) Среди двухзначных чисел, найти те, сумма цифр которых делятся на 3.
6) Найти самую большую цифру:
а) в двухзначном числе
б) трехзначном числе.



Вы находитесь на странице вопроса "1. Составить программу для нахождения произведения чисел от 1 до 15", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.