Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Заполнить массив 10х10 целыми положительными, вычислите сумму элементов строки, в которой расположен максимальный элемент и сумму вывести на экран

10-11 класс

Guzelchk 17 янв. 2015 г., 15:58:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pominov
17 янв. 2015 г., 17:00:47 (9 лет назад)

const n=3;
var
a: array[1..n, 1..n] of word;
i, j, max, MaxI, S: longint; {i и j -переменные для цикла, max - максимальный элемент, S - сумма, MaxI - номер строки, в которой расположен максимальный элемент}
begin
S:=0;
max:=0;
for i:=1 to n do
for j:=1 to n do
begin
writeln('Введите a[',i,', ', j, ']');
readln(a[i,j]);
if a[i, j]>max then
begin
max:=a[i, j];
MaxI:=i;
end;
end;//for
for j:=1 to n do s:=s+a[MaxI, j];
writeln('Сумма элементов строки, в которой расположен максимальный элемент равна ', S);
end.

Ответить

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.



Вы находитесь на странице вопроса "Заполнить массив 10х10 целыми положительными, вычислите сумму элементов строки, в которой расположен максимальный элемент и сумму вывести на экран", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.